If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[raptor] Write a Marionette test with Raptor to set mozSettings will freeze the device (Flame)

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::PerformanceTest
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: snowmantw, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 8647556 [details]
Test will freeze the device

I've found that if I port the existing Marionette test with setting some mozSettings, the device will be frozen (just like my attachment). And the console reports it's 

> Polling socket recv() timeout!

I've test it with only other behaviors without setting mozSettings. It worked fine, even with the `execAsyncScript`. So I really don't know where I could star to fix it.
(Reporter)

Comment 1

2 years ago
And another reason I feel it's hard to debug is because I don't know how to set the VERBOSE flag of marionette as true, which can print extra `console.log` to help us to debug. From Raptor's MDN page and the attempts I've tried it just doesn't work.
(Reporter)

Comment 2

2 years ago
CC Bobby and NI Eli.
Flags: needinfo?(eperelman)
(Reporter)

Comment 3

2 years ago
I may prepare more logs and video ASAP. Meanwhile it's really easy to reproduce it with the test I've attached. Maybe the test is with some flaw to freeze the device, but I'm not sure. Partly because it's from a marionette test that works well (or the "well" actually means the problems are covered).

Comment 4

2 years ago
Using the following gist I can get past the socket timeout error, but once the lock is set, the screen locks, and the result never seems to hit onsuccess/onerror, and everything hangs.

https://gist.github.com/eliperelman/dc7c55d3ff9eb4bd63e4
Flags: needinfo?(eperelman)
(Reporter)

Comment 5

2 years ago
Thanks Eli. Since the alternative works well and doesn't reproduce the bug, I close it now.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.