Closed Bug 1194293 Opened 6 years ago Closed 5 years ago

after saving to pocket and closing window with keyboard (cmd+w) the pocket panel stays open

Categories

(Firefox :: Pocket, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1171746

People

(Reporter: dietrich, Unassigned)

Details

Mac, Nightly

STR:

1. save to pocket
2. cmd+w

Expected: pocket panel closes

Actual: pocket panel stays open, even though i'm on a different tab now
Yeah, seems like we should have the panel observe things like closing the tab, switching tabs, and navigation.

Although not a big deal, because the panel should self-dismiss after a short timeout unless the mouse it over it.
(In reply to Justin Dolske [:Dolske] from comment #1)

> not a big deal

It's pretty disconcerting. And the timeout should be a lot shorter, since I've never seen it close on it's own.

Let's #greatordead this, yo.
you could make the case for it. if you want to save several pages quickly you can't, unless you click the pocket button twice which is mildly annoying/bad

click save -> cmd-w -> click save to close the old popup -> click save again to save current page -> cmd-w -> repeat
Related, I scratched my own itch and released an add-on that takes a panel-free approach: https://autonome.wordpress.com/2016/02/19/doublestitch-a-simpler-and-cleaner-pocket-for-firefox
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1171746
You need to log in before you can comment on or make changes to this bug.