Table cells are misplaced when are stretched vertically

VERIFIED FIXED in M10

Status

()

Core
Layout: Tables
P3
normal
VERIFIED FIXED
19 years ago
19 years ago

People

(Reporter: Péter Bajusz, Assigned: karnaze (gone))

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [TESTCASE] hyp-x@inf.bme.hu)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
Version:
  1999-08-15-09 apprunner on Win98

Description:
  If cells are stretched vertically in the table, they are drawn at a wrong
  position. See examples and more details.

Results:
  They are drawn upwards, with the amount of the thickness of the table border.

---
<table border=20 cellspacing=10 height=150>
  <tr>
    <td>cell content</td>
  </tr>
</table>
---

More details:
- If the table has more than one cells, then it misbehaves when ALL the cells
  are stretched. If at least one of the cells are not stretched, than all the
  cells are placed at the correct position.
- If the cell has a height specified itself which is bigger than the content
  would require, than it is NOT causing bad layout, unless the table makes it
  even taller than that value. (See table #2 and #3 in attached example.)
(Reporter)

Comment 1

19 years ago
Created attachment 1252 [details]
Testcase
(Reporter)

Updated

19 years ago
Whiteboard: [TESTCASE] hyp-x@inf.bme.hu
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 2

19 years ago
Fixed with latest checkin.

Updated

19 years ago
Status: RESOLVED → REOPENED

Updated

19 years ago
Resolution: FIXED → ---

Comment 3

19 years ago
Using 8/24 Apprunner with 8/16 testcase, tables still drawn incorrectly.
Reopening bug.
Hmmm... I just tried the 8/16 and 8/24 Windows viewer's and 8/24 apprunner and
it certainly looks fixed in today's builds to me.

Updated

19 years ago
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED
Target Milestone: M10

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 5

19 years ago
I see the problem. I was verifying this using the 8/24 M9 build and since this
bug did not have a milestone number, I didn't realize it was fixed in the 8/24
M10 build. Marking bug fixed and verified and adding M10 to milestone category.
Thanks for checking this David.
*** Bug 12193 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.