Closed Bug 119442 Opened 18 years ago Closed 18 years ago

CSS: background-image not applied correctly to <table>

Categories

(Core :: Layout: Tables, defect)

x86
Windows 2000
defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 4510
mozilla1.0

People

(Reporter: rowland.bugzilla, Assigned: karnaze)

References

()

Details

(Whiteboard: DUPEME)

Background-image when applied to a <table> or a <tr>, is inherited, and applied
as the background for table cells.

This is contary to: http://www.w3.org/TR/REC-CSS1#background-image
OS: All → Windows 2000
I've often argued that this is a bug.  Others argue it isn't.  ->HTMLTables,
although it may be a duplicate of a bug with a bugID around 1/100 its size.
Assignee: dbaron → karnaze
Component: Style System → HTMLTables
QA Contact: ian → amar
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Target Milestone: --- → mozilla1.0
This is an issue in quirks mode only.  In standards mode we don't have this
broken behavior.
Whiteboard: DUPEME
this behaviour is a quirk, which makes us compatible to IE. And we should be
somehow compatible to "stoneage" browsers :-). The inheritance has been reduced
to th td and tr while fixing bug 46268.

*** This bug has been marked as a duplicate of 4510 ***
Status: ASSIGNED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
"this behaviour is a quirk, which makes us compatible to IE"

Er, not sure if you've checked, but IE behaves per standard, with a table 
background being applied to a table and not reapplied to each cell (so graphics 
are drawn relative to the table origin.

I'd argue that this should be fixed for "quirks" mode, to be inline with the 
rest of the browser communtiy, so I've reopened accordingly.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Reduplicating.  All these arguments should be happening in bug 4510, which
covers this exact issue, among others.  Please read that bug before commenting
there further.

*** This bug has been marked as a duplicate of 4510 ***
Status: REOPENED → RESOLVED
Closed: 18 years ago18 years ago
Resolution: --- → DUPLICATE
 Verified dupe of 4510
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.