Gmail compose view keeps scrolling up as you type

RESOLVED FIXED

Status

Tech Evangelism
Desktop
RESOLVED FIXED
3 years ago
a year ago

People

(Reporter: Ehsan, Unassigned)

Tracking

(Blocks: 1 bug)

unspecified

Firefox Tracking Flags

(platform-rel +)

Details

(Whiteboard: [sitewait] [country-us] [js] [platform-rel-Google] [platform-rel-Gmail], URL)

(Reporter)

Description

3 years ago
STR:

1. Open an email and reply to it.
2. Delete the [...] thingy that expands the quoted parts.
3. Add enough lines to the email to make the editable area scrollable.
4. Start typing on the *last* line.  With every character that you type, the mail view scrolls up a little bit.

Alice, any chance you could help us please in finding a regression range?  Thanks!

Comment 1

3 years ago
This is not a recent regression.
At least, I can reproduce on Firefox4....

Comment 2

3 years ago
And I can reproduce the problem on Chrome44 if UA spoofed with "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0"

So, I think this is Google's conspiracy.
(Reporter)

Comment 3

3 years ago
I think this is a bug in Gmail.  Gmail is calling |<div>.scrollTop = NNNN;| every time a key is pressed with a call stack like this:

0 A$a(a = [object Object], b = 2039) ["https://mail.google.com/_/scs/mail-static/_/js/k=gmail.main.en.HT0y4c29Xgs.O/m=m_i,t,it/am=PiOeJsz9e38Q6wy0Sx-psPf--90nxe4_D__dmwCSvQD4____A_w_eB9_IQE/rt=h/d=1/t=zcms/rs=AHGWq9Ast3eN74CjUSX6tvujnr6wHak-pg":1655]
    this = [object Window]
1 xv.prototype.ia(a = 2039, b = [object HTMLDivElement]) ["https://mail.google.com/_/scs/mail-static/_/js/k=gmail.main.en.HT0y4c29Xgs.O/m=m_i,t,it/am=PiOeJsz9e38Q6wy0Sx-psPf--90nxe4_D__dmwCSvQD4____A_w_eB9_IQE/rt=h/d=1/t=zcms/rs=AHGWq9Ast3eN74CjUSX6tvujnr6wHak-pg":1661]
    this = [object Object]
2 za/<() ["https://mail.google.com/_/scs/mail-static/_/js/k=gmail.main.en.HT0y4c29Xgs.O/m=m_i,t,it/am=PiOeJsz9e38Q6wy0Sx-psPf--90nxe4_D__dmwCSvQD4____A_w_eB9_IQE/rt=h/d=1/t=zcms/rs=AHGWq9Ast3eN74CjUSX6tvujnr6wHak-pg":24]
    this = [object Object]
3 Eja(a = "oo", b = [function], c = [object Object]) ["https://mail.google.com/_/scs/mail-static/_/js/k=gmail.main.en.HT0y4c29Xgs.O/m=m_i,t,it/am=PiOeJsz9e38Q6wy0Sx-psPf--90nxe4_D__dmwCSvQD4____A_w_eB9_IQE/rt=h/d=1/t=zcms/rs=AHGWq9Ast3eN74CjUSX6tvujnr6wHak-pg":264]
    this = [object Window]
4 qfa/<() ["https://mail.google.com/_/scs/mail-static/_/js/k=gmail.main.en.HT0y4c29Xgs.O/m=m_i,t,it/am=PiOeJsz9e38Q6wy0Sx-psPf--90nxe4_D__dmwCSvQD4____A_w_eB9_IQE/rt=h/d=1/t=zcms/rs=AHGWq9Ast3eN74CjUSX6tvujnr6wHak-pg":156]
    this = [object Window]
5 Yd.prototype.ia/c() ["https://mail.google.com/_/scs/mail-static/_/js/k=gmail.main.en.HT0y4c29Xgs.O/m=m_i,t,it/am=PiOeJsz9e38Q6wy0Sx-psPf--90nxe4_D__dmwCSvQD4____A_w_eB9_IQE/rt=h/d=1/t=zcms/rs=AHGWq9Ast3eN74CjUSX6tvujnr6wHak-pg":153]
    this = [object Window]

Karl, do I need to gather any other information before I forward this to the Gmail team?
Component: Layout → Desktop
Flags: needinfo?(kdubost)
Product: Core → Tech Evangelism

Comment 4

3 years ago
If you have a direct contact with GMail team, please do.
Flags: needinfo?(kdubost)
Whiteboard: [contactready] [country-us] [js]
(Reporter)

Comment 5

3 years ago
Contacted the Gmail team.

Comment 6

3 years ago
> Hi, I've forwarded this to Gmail QA and will update this thread if they can reproduce. Internal bug ID 23277630.
Whiteboard: [contactready] [country-us] [js] → [sitewait] [country-us] [js]
(Reporter)

Comment 7

3 years ago
Apparently this is not Firefox specific either.
Duplicate of this bug: 1227372

Comment 9

2 years ago
If there was a vote count on getting Gmail team to fix this, I would like to add +1. This bug is pretty annoying and distracting. I am honestly surprised this has not been fixed (by gmail team) in the past 3 months!!!
Did we ever hear back from the GMail team?
Flags: needinfo?(ehsan)
(Reporter)

Comment 11

2 years ago
Nope.
Flags: needinfo?(ehsan)
See Also: → bug 1232656

Updated

2 years ago
Keywords: regression, regressionwindow-wanted
(Reporter)

Comment 12

2 years ago
FWIW I emailed them again, no response so far.
To be clear too:

Google replied on January 26 (so it's quite recent):

> The gmail team is aware of the issue and this is 
> not restricted to Firefox. I've let them know 
> about the Mozilla tracking bug.
Opps on August 18, 2015. (/me upgrades his reading skills.)
Is this issue worse in Firefox than in other browsers? (Referring to comments above saying it's cross-browser). Because I do agree it's very annoying and I find it surprising that it's left unfixed if it's annoying everywhere. If it *is* worse in Firefox, why might that be?
I can't reproduce in Chrome.
(Reporter)

Comment 17

2 years ago
While they said this is not restricted to Firefox, it doesn't mean that it affects Chrome.

Comment 18

2 years ago
If it affected Chrome, then Google wouldn't let it sit for months. Unfortunately Chrome is the new MSIE, they want to push it onto all users by releasing more and more Chrome-exclusive stuff. Firefox is a second class citizen for them.

I observe the same issue since at least a year on Fx, Ubuntu Linux.
Just to update that this issue still exists.
Whiteboard: [sitewait] [country-us] [js] → [sitewait] [country-us] [js] [platform-rel-Google] [platform-rel-Gmail]

Updated

2 years ago
platform-rel: --- → ?

Updated

2 years ago
platform-rel: ? → +

Updated

2 years ago
Blocks: 1286385
I can't reproduce anymore. Adam, can you? Karl, did we get anywhere with GMail on this one?
Flags: needinfo?(kdubost)
Flags: needinfo?(astevenson)
Rank: 3
I can't reproduce this anymore either (but I could a couple of months ago).

Comment 22

a year ago
Yup, either Firefox or Google must have changed something related to this bug. Not reproducible anymore on Linux/Firefox 48.

Lesson learned: good things come to those who wait.
Karl did reach out to Google, so let's assume they fixed it. ^_^

Thanks fore re-testing everyone.
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(kdubost)
Flags: needinfo?(astevenson)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.