All users were logged out of Bugzilla on October 13th, 2018

Inability to click on tabs when moving window to a new monitor

RESOLVED DUPLICATE of bug 1189565

Status

()

RESOLVED DUPLICATE of bug 1189565
3 years ago
3 years ago

People

(Reporter: mccr8, Unassigned)

Tracking

({regression})

unspecified
regression
Points:
---

Firefox Tracking Flags

(firefox43+ disabled)

Details

(Reporter)

Description

3 years ago
STR:
1. Open a new window. Open a new tab in that window.
2. Drag the window from one monitor to another.

I can't click on the tabs any more to switch between the two tabs. Well, I can, but (at least for a tab moved from my HiDPI monitor to a regular DPI monitor), I have to place the mouse pointer to the right of where it should be to get it to actually interact with things. The amount I have to shift to the right to get it to interact increases for tabs that are further to the right, so presumably there's some scaling factor that isn't being set properly.

The red x, orange - and green arrow thing in the upper left are not affected like this. I'm on OSX.
(Reporter)

Comment 1

3 years ago
If you move the window back to the original screen, then it is works again.

[Tracking Requested - why for this release]: This makes it very hard to use multiple monitors.
status-firefox43: --- → affected
tracking-firefox43: --- → ?
Keywords: regression
I can't reproduce this with OSX, a laptop, and an HD monitor on the latest Nightly. I also tried in aurora.  
Florin can someone on your team give this a try and see if you can reproduce it?
tracking-firefox43: ? → +
Flags: needinfo?(florin.mezei)
May be a dupe of bug 1190417, knew I'd seen it somewhere before....
(Reporter)

Comment 4

3 years ago
Yeah, that does sound the same.
Duplicate of this bug: 1190417
I've investigated this today and I can reproduce the issue using Nightly builds after August 3rd, by simply opening Firefox and moving the window to a secondary monitor. This is with Mac OS X 10.9.5 on a MacBook Pro Retina 15-inch, late 2013, and a secondary monitor connected via HDMI. After moving the window the clickable area is displaced down and to the right.

Note though that the behavior has changed in the latest Firefox 43 Nightly build: now the clickable area is no longer affected, instead the entire window display is zoomed in when moved to the secondary monitor. I've narrowed down the regression windows for when the original issue appeared and for when it disappeared introducing the new UI issue.

1. Original issue introduced - Window UI=good, Clickable area=bad

m-c:
Last good revision - 2015-07-22 - 8e5c888d0d89
First bad revision - 2015-07-23 - 1f77b78797d6
Pushlog: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=8e5c888d0d89&tochange=1f77b78797d6

m-i:
Last good revision: 6ad92b48085b5ec5532f14e0b9e3c5eb15ad9fa8
First bad revision: cfc312d8ef205bcb6a58b840459a4ccd922dcf88
Pushlog: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=6ad92b48085b5ec5532f14e0b9e3c5eb15ad9fa8&tochange=cfc312d8ef205bcb6a58b840459a4ccd922dcf88

Cause for the regression: bug 1157746.

2. Original issue fixed, new issue introduced - Window UI=bad, Clickable area=good

m-c:
Last good revision - 2015-08-30 - 7db14bebae9196d780b1d64d2fd32d1bda26828b
First bad revision - 2015-08-31 - f2518b8a7b97b5bb477e94bc9131584007aac887
Pushlog: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=7db14bebae9196d780b1d64d2fd32d1bda26828b&tochange=f2518b8a7b97b5bb477e94bc9131584007aac887

m-i:
20:22.98 LOG: MainThread Bisector INFO Last good revision: 292d13beeb7b984dfa4effe685f2681dc1b2e941
20:22.98 LOG: MainThread Bisector INFO First bad revision: 2e731191c6920f29f12b4592466f9a4dc2df1842
20:22.98 LOG: MainThread Bisector INFO Pushlog: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=292d13beeb7b984dfa4effe685f2681dc1b2e941&tochange=2e731191c6920f29f12b4592466f9a4dc2df1842

Fix for this issue and cause for new regression: bug 1189565.

I'm marking this as a duplicate of bug 1189565, and will follow up with a new bug blocking bug 1189565 for the new issues.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(florin.mezei)
Resolution: --- → DUPLICATE
Duplicate of bug: 1189565
The fix in bug 1189565 has been backed out for causing the UI issues mentioned above and filed in bug 1201053. This means this issue will be back while they try to find another solution. As a workaround you can set layers.async-pan-zoom.enabled to false in about:config to avoid the clickable area issue.
layers.async-pan-zoom.enabled is false by default now on aurora, so this will no longer affect 43.
I think the remaining cases for monitor issues are covered in bug 1205372.
status-firefox43: affected → disabled
You need to log in before you can comment on or make changes to this bug.