ThreeJS renders black screen

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: nick, Unassigned)

Tracking

40 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8647764 [details]
Hard to capture what happens but you can see the flashing in this video.

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150807085045

Steps to reproduce:

ThreeJS scene setup on localhost worked in Firefox and Chrome, after updating Firefox it flashes the scene very quickly and then is black.


Actual results:

Rendered scene shows very briefly then turns black.


Expected results:

Scene should continue to render.

Comment 1

3 years ago
Could you attach a minimal testcase, please.
Flags: needinfo?(nick)
Keywords: testcase-wanted
(Reporter)

Comment 2

3 years ago
Created attachment 8647911 [details]
Simple testcase, just a copy of the basic threejs tutorial

The screen produced is apparently not always black. It is also not related to the renderer clear color set in THREE.

If you take a look at the attached example it is white, if you look at examples shown here: https://stemkoski.github.io/Three.js they are purple (in source you can see that the purple is coming from a skybox).

I am new to reporting bugs here, apologies if I'm not providing the greatest report.
Flags: needinfo?(nick)

Comment 3

3 years ago
On your attached testcase, I see a green square rotating on a black blackground.

Could you type about:support in the location bar and copy the section "graphics", please.
(Reporter)

Comment 4

3 years ago
That's interesting, my brother actually has the same issue - we both have Windows 10 and the same graphics card.

Graphics
--------

Adapter Description: NVIDIA GeForce GTX 960
Adapter Drivers: nvd3dumx,nvwgf2umx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um,nvwgf2um
Adapter RAM: 2048
Asynchronous Pan/Zoom: none
Device ID: 0x1401
Direct2D Enabled: Blocked for your graphics driver version.
DirectWrite Enabled: false (10.0.10240.16430)
Driver Date: 7-22-2015
Driver Version: 10.18.13.5362
GPU #2 Active: false
GPU Accelerated Windows: 1/1 Direct3D 11 WARP (OMTC)
Subsys ID: 29663842
Supports Hardware H264 Decoding: false
Vendor ID: 0x10de
WebGL Renderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 960 Direct3D11 vs_5_0 ps_5_0)
windowLayerManagerRemote: true
AzureCanvasBackend: skia
AzureContentBackend: cairo
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0

Comment 5

3 years ago
With Win 10, you have to update to the latest drivers, because there are many bugs with Win 10.
For your Nvidia GPU, the latest drivers are 355.60:
http://www.nvidia.com/download/driverResults.aspx/89124/en-us

Could you update the drivers and check if it's fixed or not, please.
Flags: needinfo?(nick)

Comment 6

3 years ago
EDIT: I read 2 reports about users with Win 10 who had "black screens" with Google Maps after 1 or 2 sec. They fixed it by updating the drivers, so it's probably the same underlying issue.
(Reporter)

Comment 7

3 years ago
I had already updated my drivers but for some reason I didn't think to clear my cache. After doing so the problem was resolved.

Thank you for your time!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(nick)
Resolution: --- → INVALID
Keywords: testcase-wanted
You need to log in before you can comment on or make changes to this bug.