[Aries][v2.5][Camera]The photo will be in landscape and stretched even the device is in portrait mode.

VERIFIED DUPLICATE of bug 1182557

Status

Firefox OS
Gaia::Camera
VERIFIED DUPLICATE of bug 1182557
3 years ago
3 years ago

People

(Reporter: Annabelle, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.2 unaffected, b2g-master affected)

Details

(Whiteboard: [2.5-aries-test-run-1])

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8647949 [details]
Bug log: logcat_0208.txt

[1.Description]:
[Aries][v2.5][Camera] Previewing an image, tap share icon but return to homescreen, then relaunch Camera to check the Preview of this image. The image itself is in landscape mode and stretched.

Found time:02:08
See attachment: logcat_0208 & Aries_kk_v2.5.3gp

[2.Testing Steps]: 
Premise:Keep the device in portrait mode.
1.Launch Camera and Take a ptoto.
2.Tap gallery thumbnail to view it.
3.Tap the share icon
4.Tap Home key after the share activity picker appears
5.Relaunch Camera and tap the gallery thumbnail again.
6.Observe the photo in Preview.

[3.Expected Result]: 
6.The photo is in portrait mode and in normal size.

[4.Actual Result]: 
6.The photo itself is in landscape and stretched.

[5.Reproduction build]: 
Device: Aries KK 2.5(Affected)
Build ID               20150812230643
Gaia Revision          52f3ea58df38e5427f6afeb636bc6ad01d24022f
Gaia Date              2015-08-12 16:40:43
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/7649ffe28b67aa2dad0f67ea01500c0ff91b2bac
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150812.222959
Firmware Date          Wed Aug 12 22:30:07 UTC 2015
Bootloader             s1

Device: Flame KK 2.5(Unaffected)
Build ID               20150813150207
Gaia Revision          acfaa3957e65d52a0af2185149628a520edcc7e2
Gaia Date              2015-08-13 12:34:28
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/cdf53a4dee219aabec7462888875bac08b093edc
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150813.184539
Firmware Date          Thu Aug 13 18:45:52 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Flame KK 2.2(Unaffected)
Build ID               20150813032504
Gaia Revision          102f1299e9eafe3760e1deb44d556b5c4f36b5af
Gaia Date              2015-08-06 20:46:56
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/9295034c0ee3
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150813.065103
Firmware Date          Thu Aug 13 06:51:14 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Comment 1

3 years ago
Created attachment 8647951 [details]
Bug video: Arise_kk_v2.5.3gp
(Reporter)

Updated

3 years ago
status-b2g-v2.2: --- → unaffected
status-b2g-master: --- → affected
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1182557
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.