Closed Bug 1194829 Opened 9 years ago Closed 9 years ago

Rename sweep to sweepChildren because shu said so

Categories

(Core :: JavaScript Engine, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla43
Tracking Status
firefox43 --- fixed

People

(Reporter: sfink, Assigned: sfink)

Details

Attachments

(1 file)

<shu> jandem: if they are both dead, we should not be inside IonCacheEntry::sweep
<shu> jandem: that sweep is better named as sweepChildren
<jandem> shu: ah i see, makes sense
<sfink> shu: is that also true of BaselineEntry and IonEntry? s/sweep/sweepChildren/, I mean. (I'm not actually following your conversation, just saw that last line)
<cloudshu> sfink: it is
Comment on attachment 8648187 [details] [diff] [review]
Rename sweep to sweepChildren because shu said so

Review of attachment 8648187 [details] [diff] [review]:
-----------------------------------------------------------------

Can't argue with that! Thanks.

::: js/src/jit/JitcodeMap.h
@@ +930,5 @@
>          }
>          return markedAny;
>      }
>  
>      void sweep(JSRuntime* rt) {

This should also be sweepChildren.
Attachment #8648187 - Flags: review?(shu) → review+
https://hg.mozilla.org/mozilla-central/rev/3764bcb8edd1
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla43
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: