Closed Bug 1194908 Opened 4 years ago Closed 4 years ago

make /resulset endpoint work with revision values greater than 12

Categories

(Tree Management :: Treeherder: API, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1079796

People

(Reporter: camd, Unassigned)

References

Details

If the ``revision`` param is passed in that is 40 chars in length, then treeherder won't find the revision.

Investigate whether we always do and should store revisions at 12.  If someone searches by a 40 char revision, we should be able to find it if we only stored 12 chars.

However, if the API always truncates the value to 12, but we SOMETIMES store the revision as 40 chars, then we will not be able to find any resultsets with revision longer than 12 chars.
Blocks: 1194801
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1079796
You need to log in before you can comment on or make changes to this bug.