e10s notification ‘You’re now helping to test multi-process in Firefox Dev…’ is unreadable with Gtk3

RESOLVED DUPLICATE of bug 1187203

Status

()

Core
Widget: Gtk
RESOLVED DUPLICATE of bug 1187203
2 years ago
2 years ago

People

(Reporter: beta, Unassigned)

Tracking

42 Branch
Unspecified
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8648312 [details]
Screenshot.2015-08-15.010650.png

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20150814004009

Steps to reproduce:

Launch Firefox


Actual results:

No tabs loaded (filed thay via the e10s ‘give us feedback’ question), and the browser presented an alert toolbar with white text on a light grey background saying: 

You’re now helping to test multi-process in Firefox Developer Edition! Please report problems you find.


Expected results:

The toolbar should have been themed correctly.

Comment 1

2 years ago
It looks like a theme issue.

Are you running gtk3?

Updated

2 years ago
Blocks: 516752
(Reporter)

Comment 2

2 years ago
(In reply to Loic from comment #1)
> Are you running gtk3?

It appears this build is running with libgtk3, yeah.

Updated

2 years ago
Component: Untriaged → Widget: Gtk
OS: Unspecified → Linux
Product: Firefox → Core
Summary: e10s toolbar ‘You’re now helping to test multi-process in Firefox Dev…’ is unreadable → e10s notification ‘You’re now helping to test multi-process in Firefox Dev…’ is unreadable with Gtk3
Hey Andrew, know what's happening here?
Flags: needinfo?(acomminos)

Updated

2 years ago
tracking-e10s: --- → -
Yup, seems to be a duplicate of bug 1187203, caused by some themes having a background-image set for tooltips but no background-colour.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
tracking-e10s: - → ---
Flags: needinfo?(acomminos)
Resolution: --- → DUPLICATE
Duplicate of bug: 1187203
You need to log in before you can comment on or make changes to this bug.