e10s in Firefox Developer Edition 42.0a2 (2015-08-14) seems to stall GMail loading

RESOLVED DUPLICATE of bug 1193796

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 1193796
3 years ago
3 years ago

People

(Reporter: znmeb, Unassigned)

Tracking

42 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20150814004009

Steps to reproduce:

1. Updated Firefox to 42.0a2 (2015-08-14). Host is 64-bit Debian "stretch".
2. Got the message that e10s was enabled. Went about my typical browsing.
3. TweetDeck works fine. Clicked on a GMail bookmark and nothing happened.



Actual results:

I opened a new tab and typed in the GMail URL. It just stalled. I disabled e10s and restarted. It took a while for it to connect but GMail eventually came up.

Other Google services - Drive, for example - seem to be working both with and without e10s. It looks like only GMail is having problems.
(Reporter)

Updated

3 years ago
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
(Reporter)

Comment 1

3 years ago
I don't think this is just e10s and it seems to be many of the Google services. I've also seen some big CPU load numbers from Firefox in 'top'. GMail is the worst but Google Drive and Sheets are also showing problems.

Updated

3 years ago
Blocks: 516752
(Reporter)

Comment 2

3 years ago
I tried Nightly (43) and it seems to be slightly better - GMail opens with e10s disabled, but I can't open a folder.

Comment 3

3 years ago
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:43.0) Gecko/20100101 Firefox/43.0 ID:20150815030208 CSet: 2ddfc9180971a212127a370911ba2e8ef36a6605

WITHOUT e10s turned on.

Today, this update, it's not working for me with Gmail.  I click on an email to read it, and Gmail still says "Still working..." at the top of the window.  Meanwhile, Chrome is working, I started reading email, got the notification that this was an e10s, opened up the link, copied the link and opened it in Firefox, not Chrome (already logged in).  And Gmail is still working...  Uh-huh.
(Reporter)

Comment 4

3 years ago
(In reply to Bryan Price from comment #3)
> Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:43.0) Gecko/20100101
> Firefox/43.0 ID:20150815030208 CSet: 2ddfc9180971a212127a370911ba2e8ef36a6605
> 
> WITHOUT e10s turned on.
> 
> Today, this update, it's not working for me with Gmail.  I click on an email
> to read it, and Gmail still says "Still working..." at the top of the
> window.  Meanwhile, Chrome is working, I started reading email, got the
> notification that this was an e10s, opened up the link, copied the link and
> opened it in Firefox, not Chrome (already logged in).  And Gmail is still
> working...  Uh-huh.

This is definitely a strange phenomenon. I don't know what to do to troubleshoot it. I have two machines, a workstation and a laptop, both running Debian "stretch" (testing). Both are 64-bit, the laptop is Intel and the workstation is AMD. It fails on GMail with or without e10s on the workstation, and is behaving less than admirably on other Google services. But it's working fine with e10s *enabled* on the laptop across all the Google services.

So it might be some bizarre JavaScript engine thing, or it might be WiFi in a coffee shop (working) vs. wired at home (workstation).

I can try it in Windows on the laptop - I'm guessing it'll work fine. I wish it would just crash or something so it would send Mozilla a dump / traceback. ;-)
(Reporter)

Comment 5

3 years ago
As I expected, it's working fine on Windows (8.1 Pro, 64-bit, Intel CPU) - Firefox Developer Edition 42.0a2 (2015-08-15)

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1193796
You need to log in before you can comment on or make changes to this bug.