Status

Other Applications
DOM Inspector
RESOLVED DUPLICATE of bug 1078121
3 years ago
3 years ago

People

(Reporter: Chuck Baker, Unassigned)

Tracking

({helpwanted})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
DOM Inspector does not load/work in Fx 42.0a2 (2015-08-16).

Tools > Web Developer > DOM Inspector generates message in browser console:

TypeError: content is null browser.xul:1:1

Tried with a new, otherwise empty profile. Same results.
(Reporter)

Updated

3 years ago
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64
This is due to the multiprocess changes in Firefox that are enabled by default in 42.  No one is working on DOM Inspector as far as I know, so the only way to fix this is to turn off multiprocess mode from the preferences and then restart.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 7 → All
Hardware: x86_64 → All
Version: 2.0 → unspecified

Comment 2

3 years ago
(In reply to Colby Russell :crussell (no longer Mozilla-ing) from comment #1)
> This is due to the multiprocess changes in Firefox that are enabled by
> default in 42.  No one is working on DOM Inspector as far as I know, so the
> only way to fix this is to turn off multiprocess mode from the preferences
> and then restart.
Any hints on how to fix this?
Flags: needinfo?(Sevenspade)
No idea.  I had stopped focusing on Mozilla-related projects almost entirely even by the time I had written that comment.
Flags: needinfo?(Sevenspade)

Comment 4

3 years ago
In Multiprocess Firefox the content is running in another process.

From: http://mxr.mozilla.org/comm-central/source/mozilla/devtools/server/actors/inspector.js?rev=cc2af13f040c#187

// When the user selects a node to inspect in e10s, the parent process
// has a CPOW that wraps the node being inspected.  It uses the
// message manager to send this node to the child, which stores the
// node in gInspectingNode. Then a findInspectingNode request is sent
// over the remote debugging protocol, and gInspectingNode is returned
// to the parent as a NodeFront.

Since this functionality is expected to be present in Firefox we could piggyback on the remote debugging protocol.
Keywords: helpwanted

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1078121
You need to log in before you can comment on or make changes to this bug.