Closed Bug 1195145 Opened 8 years ago Closed 7 years ago

Wrong audio param value when using linearRampToValueAtTime

Categories

(Core :: Web Audio, defect, P2)

42 Branch
Unspecified
macOS
defect

Tracking

()

RESOLVED DUPLICATE of bug 893020

People

(Reporter: alemangui, Assigned: padenot)

References

()

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/44.0.2403.130 Safari/537.36

Steps to reproduce:

This problem is related to web audio. The following JSfiddle describes my situation: http://jsfiddle.net/nhysww69/1/

I am using linearRampToValueAtTime to decrease the gain of a gainNode. If I try to access the gain value during the fadeout, I will get the wrong value - in this case the initial one.

On the other hand, Chrome outputs the correct values decreasing with time.


Actual results:

I get gainNode.gain.value always equal to 1 even while it's decreasing due to linearRampToValueAtTime and thus it is lower to one as time passes by.


Expected results:

The correct gain values should've been shown (like they are if the JSFiddle is run in Chrome)
OS: Unspecified → Mac OS X
Component: Untriaged → Web Audio
Product: Firefox → Core
We have the correct behaviour per spec, Chrome and WebKit are wrong here.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → INVALID
I think Chrome and Webkit are OK if I'm understanding this part of the spec correctly:
--------
2.5.3 Computation of Value

1. An intrinsic parameter value will be calculated at each time, which is either the value set directly to the value attribute, or, if there are any scheduled parameter changes (automation events) with times before or at this time, the value as calculated from these events. (...) When read, the value attribute always returns the intrinsic value for the current time.
--------
The value as calculated from scheduled parameter changes is not being returned in Firefox.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Flags: needinfo?(padenot)
I've found a nice way to do this, I'll do a quick implementation soon, it's easy. I thought there was another bug, but I can't find it.
Assignee: nobody → padenot
Flags: needinfo?(padenot)
Status: UNCONFIRMED → NEW
Rank: 25
Ever confirmed: true
Priority: -- → P2
Status: NEW → RESOLVED
Closed: 8 years ago7 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.