OPML import of grouped feeds fails

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: bbrandl.atoss, Unassigned)

Tracking

31 Branch

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

3 years ago
Created attachment 8648582 [details]
feedly-2015-08-17.opml

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/43.0.2357.130 Chrome/43.0.2357.130 Safari/537.36

Steps to reproduce:

- Create new feed account
- Import attached OPML file


Actual results:

- The folders are imported, but empty
- On refresh items are fetched
- On restart folders persit, but RSS feeds are gone


Expected results:

- RSS feeds should be listed underneeth their parent folders
- Feeds should persist on restart

Comment 1

3 years ago
Importing that file works as intended and persists on restart. Feeds are intentionally not fetched during the import process.

A feed folder in Tb can contain any number of subscriptions and the export/import functions need to handle this design.  So an <outline> tag with type="rss" attribute is a subscription and not a folder; a folder is an <outline> tag without type="rss".

The error console has extensive logging of what's going on. See also the Learn More link.
(Reporter)

Comment 2

3 years ago
Created attachment 8650302 [details]
Screenshot after OPML Import
(Reporter)

Comment 3

3 years ago
Created attachment 8650303 [details]
Screenshot after Restart
(Reporter)

Comment 4

3 years ago
Sorry, maybe I didn't express myself clearly. Please have a look at the attached screenshots.

After the initial import of OPML file, I see the following feed list. All item are contained: attachment 8650302 [details].

If I do a restart after the import, all items are gone. See attachment 8650303 [details]

Comment 5

3 years ago
In your [profile]/Mail folder there should be a folder Feeds.  In that folder is the database named feeds.rdf and it looks like it's not there or corrupted.  Please attach it here if it exists.  Perhaps some antivirus or cleaner is removing it.  Also look in the error log for suspicious messages and attach here.
(Reporter)

Comment 6

3 years ago
Created attachment 8650433 [details]
feeds.rdf

The feeds.rdf file exists, but hasn't much content.

A virus scanner isn't involed, thunderbird is executed under Linux. Suspiciously the error log doesn't show any feeds related messages.

Comment 7

3 years ago
Make sure all extensions are disabled. Then open the error console and import again, do not close Tb, what does feeds.rdf look like?  Then close Tb, what happens to the file?
(Reporter)

Comment 8

3 years ago
Disabled all extensions.

Following scenario reproduces the issue:
- Start thunderbird
- Add new feeds
- Import OPML feeds
- Close dialog
-> No feeds.rdf file in Mail directory
- Refresh feeds
-> feeditems.rdf gets created
- Restart thunderbird
- Refresh feeds
- Mark all as read
- Delete read feed/Empty trash
- Restart thunderbird
-> Feed list is gone
-> feeds.rdf is 321 bytes

This is kinda different from my initial scenario, but has the same effect.

Comment 9

3 years ago
feeds.rdf is in Mail/Feeds.  what does 'delete read feed' mean?  are you deleting messages or the folder?

clearly you're deleting the folder, there's no other way feeds.rdf is empty.
(Reporter)

Comment 10

3 years ago
(In reply to alta88 from comment #9)
> feeds.rdf is in Mail/Feeds.  what does 'delete read feed' mean?  are you
> deleting messages or the folder?
I'm deleting the messages. 
In the main view, where the accounts are listed. A feed folder is selected, then all messages are marked as read and removed by "Ctrl+A" -> delete.
(Reporter)

Comment 11

3 years ago
This is really weird. I'm trying to reproduce the scenario from comment #8. But now the feeds persit, no matter what is done.

I saw the disappearing feeds many times, and filed this bug to investigate and finally solve the issue. Something is there which empties the feeds.rdf upon thunderbird restart.

Comment 12

3 years ago
Nope, the only way is for you to have moved those folders to trash, which unsubscribes and leaves feeds.rdf in its initial empty state per attachment, and moved them back.  And without reproducible steps, nothing more to do here.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.