Thunderbird is deleting inbox on startup since version 38.1.0

RESOLVED DUPLICATE of bug 1175242

Status

Thunderbird
Untriaged
--
major
RESOLVED DUPLICATE of bug 1175242
2 years ago
2 years ago

People

(Reporter: pavel.janda, Unassigned)

Tracking

38 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150807085045

Steps to reproduce:

For reason of easy (low filesize) backuping to cloud, I've changed mailbox from default Thunderbird mailbox (one huge file) to "maildir" version (each mail has its own file). I've did that a few years ago and used that with pleasure till version 38.1.0 (and now I have 38.2.0 and this bug is still there). On startup of Thunderbird, Inbox directory is deleted (other directories are not deleted - only inbox).


Actual results:

After starting up, when Inbox dir. is deleted, I see whole list of emails, but I cannot see detail of email in Inbox. When I restore Inbox dir from backup, all works OK till next startup of Thunderbird when Inbox is again deleted. This happend only to my "maildir" mailboxes. I have one mailbox in default format (mbox?) and this is OK. Only those in maildir format are deleted.


Expected results:

Do not delete my inbox :)
This  is unfortunately a recently discovered issue
Severity: normal → major
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1175242
You need to log in before you can comment on or make changes to this bug.