[Dialer] Volume Audio Channel is incorrect after a call

RESOLVED DUPLICATE of bug 1183870

Status

Firefox OS
Gaia::System::Audio Mgmt
RESOLVED DUPLICATE of bug 1183870
2 years ago
2 years ago

People

(Reporter: julienw, Assigned: evanxd)

Tracking

({dogfood, qawanted})

unspecified
ARM
Gonk (Firefox OS)
dogfood, qawanted

Firefox Tracking Flags

(blocking-b2g:2.5?)

Details

(Reporter)

Description

2 years ago
STR:
1. Check that the volume buttons control the general notification channel. (We see the icon with a handset and the 3 circle arcs representing the sound wave + it has ~15 steps)
2. start a call, wait that the call is established.
3. Check that the volume buttons control the phone communication channel (We see the icon with a handset only + it has ~6 steps)
4. hang up the call.
5. Use the volume buttons.

Expected:
* They should control the general notification channel like in step 1.

Actual:
* They control the phone communication channel like in step 3.
* Even after several minutes/hours/days.
* They work back correctly after a reboot or after I change the channel volume from the settings app.

[Blocking Requested - why for this release]:
I think this is a regression but let's ask QA.
(Reporter)

Updated

2 years ago
See Also: → bug 1006356
(Assignee)

Updated

2 years ago
Assignee: nobody → evan
(Assignee)

Comment 1

2 years ago
Hi Julien,

This bug is just a duplicate of Bug 1183870.
And Bug 1183870 is blocked by Bug 1191207.

This will be resolved after Bug 1191207 is fixed.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1183870
You need to log in before you can comment on or make changes to this bug.