[e10s] Different presentation for a pull down menu

RESOLVED WONTFIX

Status

()

P4
normal
RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: sylvestre, Unassigned)

Tracking

Trunk
Unspecified
Linux
Points:
---

Firefox Tracking Flags

(e10s+, firefox42 affected, firefox43 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8648606 [details]
e10slayout.png

Some pull down menus have a different rendering with or without e10s.
The screenshot should be explicit.

This is affecting GNU/Linux
(Reporter)

Updated

3 years ago
status-firefox42: --- → affected
(Reporter)

Updated

3 years ago
tracking-e10s: --- → ?
This seems familiar.  A polish bug. But a couple of quick searches doesn't turn up a dupe.

Updated

3 years ago
tracking-e10s: ? → +
(Reporter)

Updated

3 years ago
Duplicate of this bug: 1132561

Comment 3

3 years ago
User Agent 	Mozilla/5.0 (X11; Linux x86_64; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID 	20160207030402

Still reproduces on latest Aurora (46.0a2) and latest Nightly (47.0a1). The rendering is different with or without e10s.

Comment 4

3 years ago
cleaner styling under e10s.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 5

3 years ago
> cleaner styling under e10s.
Sorry but could you explain why e10s is changing the style? Thanks
Flags: needinfo?(jmathies)

Comment 6

3 years ago
(In reply to Sylvestre Ledru [:sylvestre] from comment #5)
> > cleaner styling under e10s.
> Sorry but could you explain why e10s is changing the style? Thanks

Drop downs under e10s are a different type of xul element - we have to remote their display. The select is in content, the child window gets created in chrome. Jeff Griffiths took a look at this felt the new styling was cleaner. Feel free to reopen to discuss, but we wont block on this.
Flags: needinfo?(jmathies)
Priority: -- → P4
(Reporter)

Comment 7

3 years ago
Ok, thanks.
I don't have an opinion on the new style and I won't bikeshed on this.
I was just surprised to discover that an architectural change impacts the l&f of the browser.
You need to log in before you can comment on or make changes to this bug.