[Topcrashers] Optimize page loading time

RESOLVED WORKSFORME

Status

Socorro
Webapp
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: adrian, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
Quoting Peter (https://github.com/mozilla/socorro/pull/2935#issuecomment-128438046): 

> I did some basic benchmarking (using randomization)
> 
> WITHOUT ANY CACHING (about 15 rounds per URL):
> 
> URL                                                     Average    Median
> /topcrashers/?product=Firefox&version=41.0a2&days=7     2.2944     2.2452
> /topcrasher/products/Firefox/versions/41.0a2?days=7     1.7973     1.8018
> 
> and with model caching switched on
> 
> WITH CACHING (about 15 rounds per URL):
> 
> URL                                                     Average    Median
> /topcrashers/?product=Firefox&version=41.0a2&days=7     1.2246     1.2415
> /topcrasher/products/Firefox/versions/41.0a2?days=7     0.3227     0.3341
(Reporter)

Updated

3 years ago
Blocks: 1195304
The new Top Crasher does *two* (SuperSearch) queries. The first one doesn't specify a date. It's just "now". The second query however, does this "now" minus 7 days. The problem is then that the second query has a parameter in it with seconds which means it can never benefit from our data-fetching caching on the second one.
No longer blocks: 1195304
(Reporter)

Comment 2

2 years ago
This is too vague. If we encounter serious performance problems, we'll work on concrete solutions.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.