Closed Bug 1195321 Opened 5 years ago Closed 5 years ago

'Thumbnail removed' message overlaps search bar from newtab

Categories

(Firefox :: New Tab Page, defect)

defect
Not set
Points:
1

Tracking

()

VERIFIED FIXED
Firefox 43
Iteration:
42.3 - Aug 10
Tracking Status
firefox42 --- verified
firefox43 --- verified

People

(Reporter: bogdan_maris, Assigned: mzhilyaev)

References

(Blocks 2 open bugs)

Details

(Keywords: regression)

Attachments

(5 files)

Affected platforms: 
- Windows 7 64-bit
- Mac OS X 10.10.4
- Ubuntu 14.04 32-bit

Affected builds:
- latest Nightly 43.0a1
- latest Aurora 42.0a2

STR:
1. Open Firefox and navigate to about:newtab
2. Reduce the browsers width
2. Delete one thumbnail

Expected results: No visual issues can be seen.

Actual results: The undo menu overlaps Search bar from new tab
Probably made worse from bug 1180387 with it pushing the search bar upwards.
Blocks: 1180387
Keywords: regression
Blocks: Sprint_CS_S1
Iteration: --- → 42.3 - Aug 10
Points: --- → 1
(In reply to Ed Lee :Mardak from comment #1)
> Probably made worse from bug 1180387 with it pushing the search bar upwards.

1180387 change was never uplifted to Aurora 42.0a2.
I verified that latest Aurora 42.0a2 build has the problem, and it does not have 1180387 changes.
Since 1180387 is not the root cause, 1180387 should depend on this regression. 
Hence, removing the dependency.
No longer blocks: 1180387
(In reply to maxim zhilyaev from comment #2)

> Since 1180387 is not the root cause, 1180387 should depend on this

This should read - "1180387 should NOT depend on this regression"
It was made worse by bug 1180387 because before that change, there usually was empty space for the undo message.
Blocks: 1180387
When I said "it was made worse," I mean this bug is more likely to be seen by more users. Yes, even without the patch, it's possible to trigger the bug if the user's window is sized a certain way, but with the patch, the bug happens for a lot more window sizes.
Attached patch 1195321.patch.v1Splinter Review
Increasing top margin of the search-container to avoid overlaps with undo message.
Attachment #8650202 - Flags: review?(edilee)
Requesting info from aaron if this would be an acceptable fix.
Flags: needinfo?(athornburgh)
Comment on attachment 8650202 [details] [diff] [review]
1195321.patch.v1

Approach is fine. Wait for dcrobot's spec on how far the search bar should be from the undo container as well as the customize/gear button.
Attachment #8650202 - Flags: review?(edilee) → review+
would it be possible to show this beneath the actual tile deleted, instead of in a fixed position upper/left?
Flags: needinfo?(athornburgh)
(In reply to Aaron from comment #10)
> would it be possible to show this beneath the actual tile deleted, instead
> of in a fixed position upper/left?

It could be, but I would prefer to file that as a separate bug. I need to uplift all changes related to 1180387 (this bug included) to aurora/beta, preferably this Friday. I would  much prefer if we do a simple fix now.
Max, I'm good with your solution. Don't worry about my comment above for now.

Thanks.
Assignee: nobody → mzhilyaev
Confirming the fix on latest Nightly, build ID: 20150825030212.
Tested on Windows 7 64-bit, Windows 10 64-bit, Mac OS X 10.9.5 and Ubuntu 12.04 32-bit.

Filled bug 1198754, the cog wheel overlaps the thumbnail removal message when the window is resized.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
QA Contact: cornel.ionce
Approval Request Comment
[Feature/regressing bug #]:
A regression of 1180387
[User impact if declined]:
Significant - UX looks ugly
[Describe test coverage new/current, TreeHerder]:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=ab58a4b34f15
[Risks and why]: 
Low risk - the change is one-liner for css margin setting

[String/UUID change made/needed]: NONW
Attachment #8654659 - Flags: approval-mozilla-aurora?
Attachment #8654659 - Attachment description: 1195321.aurora.v1 → V1. 1195321 aurora patch
Comment on attachment 8654659 [details] [diff] [review]
V1. 1195321 aurora patch

Bad UX, taking it.
Attachment #8654659 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
The uplift of bug 1194895 actually fixed those failures before this backout landed. Re-landed.
https://hg.mozilla.org/releases/mozilla-aurora/rev/214492ce4267
Blocks: Sprint_CS_S2
Blocks: 1205313
No longer blocks: 1205313
Verified fixed on Windows 7 64-bit, Windows 10 32-bit, Mac OS X 10.9.5 and Ubuntu 12.04 32-bit using Firefox 42 beta 2, build ID: 20150928102225.
You need to log in before you can comment on or make changes to this bug.