New Bookmark pop-up appears in detailed mode for a second then it switches to default

RESOLVED WORKSFORME

Status

()

Toolkit
Places
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: bogdan_maris, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox43 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8648741 [details]
Screencast showing the issue

Affected platforms: 
- Windows 7 64-bit
- Mac OS X 10.10.4
- Ubuntu 14.04 32-bit

Affected builds:
- latest Nightly 43.0a1
- latest Aurora 42.0a2

STR:
1. Open Firefox and navigate to Library 
2. Open History and right click a website
3. Select Bookmark this page...

Expected results: No visual issues can be seen.

Actual results: For a second the New Bookmark pop-up can be seen in detailed mode, after that it goes back to normal.

With Mac OS X, the effect is more visible.

Notes:
- This is a regression, does not reproduce with FF 38.0 RC, will investigate further for a range.
- This reproduces both with e10s enabled and disabled
we converted part of the code to async initialization, and that may be the cause. the work there is still in progress (paused at the moment)
I think this should have been fixed by bug 1199496
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.