Closed Bug 1195333 Opened 5 years ago Closed 5 years ago

List diaspora as a provider

Categories

(Firefox Graveyard :: SocialAPI, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: fabricio, Unassigned)

Details

Attachments

(2 files)

As a diaspora* user, it got me some time to find the proper sharer to install: https://sharetodiaspora.github.io/about/ (see the "Firefox Social API Extension" section). This should come integrated by default in the browser, or, at least be listed on the View more website at https://activations.cdn.mozilla.net/en-US/

Steps to reproduce:

- Include the "Share this page" button on your toolbar using the customize option from the menu
- Go to a page you want to share on your diaspora* stream
- Click on the paper airplane icon
- Look for a diaspora* provider to add

Expected results:
- diaspora* is a default option along with twitter and facebook
or
- diaspora* is listed on the View more page

Actua results
The option for diaspora* as a provider is not there, and the user have to look for it on Google, which will point to several (many of them broken) old addons and only after many attempts the user will find an option that integrates with the built-in social api at https://sharetodiaspora.github.io/about/
Having the share functionality on github is to ephemeral and wouldn't be something I would include on the share directory.  

My first suggestion would be to get the share activation included in the diaspora distribution.  This would allow users to activate share directly on their own pod without any intermediary.  Due to the way activation works, this mechanism would not be something that would work from the directory (default options in the share panel or on the site via view more).

My second suggestion is to get a trusted intermediary (e.g. diasporafoundation.org) to host the cross-domain share, that mechanism could be included in the directory.
Ok!

I have opened an issue on diaspora*'s github to further discuss this: https://github.com/diaspora/diaspora/issues/6327
As discussed on IRC, I have set up a share application on our official project domain and changed some stuff to make it work properly. The sharer, including a button to add it to Firefox, can be found at https://share.diasporafoundation.org/about.html

Since this is now hosted by the projects core team, we'd like to see us included in the directory. :) I have attached two screenshots. Please ping me if I can help somehow.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.