ReferenceError: smtp is not defined when opening Troubleshooting Information, causing whole page to have no data

RESOLVED FIXED in Thunderbird 43.0

Status

Thunderbird
Mail Window Front End
--
major
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: Ian Neal, Assigned: aceman)

Tracking

Trunk
Thunderbird 43.0

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

4.14 KB, patch
Magnus Melin
: review+
Ian Neal
: feedback+
Details | Diff | Splinter Review
(Reporter)

Description

2 years ago
STR
1. Start TB
2. Click Help, Troubleshooting Information
3. Look in error console

Expected Result
1. Account information on troubleshooting page
2. No error in error console

Actual Result
1. Account information is empty on troubleshooting page
2. Following error in error console:
Timestamp: 17/08/15 15:55:26
Error: ReferenceError: smtp is not defined
Source File: chrome://messenger/content/about-support/accounts.js
Line: 75
(Assignee)

Comment 1

2 years ago
I can see the error in the console. The whole troubleshooting page is now empty.
Assignee: nobody → acelists
Severity: normal → major
Status: NEW → ASSIGNED
Component: Untriaged → Mail Window Front End
(Assignee)

Updated

2 years ago
Summary: ReferenceError: smtp is not defined when opening Troubleshooting Information → ReferenceError: smtp is not defined when opening Troubleshooting Information, causing whole page to have no data
(Assignee)

Comment 2

2 years ago
Created attachment 8649336 [details] [diff] [review]
patch

I don't really know why, but this solves it for me. Maybe this form of nested loops/array member generators got broken/redesigned in m-c?
Attachment #8649336 - Flags: feedback?(iann_bugzilla)
(Reporter)

Comment 3

2 years ago
Comment on attachment 8649336 [details] [diff] [review]
patch

Yes, it fixes it for me, but need to find out why it broke just in case there is other code that needs to be fixed too (and peace of mind too).
Attachment #8649336 - Flags: feedback?(iann_bugzilla) → feedback+
(Assignee)

Comment 4

2 years ago
Jcranmer, do you know anything about these JS constructs?
Flags: needinfo?(Pidgeot18)
(In reply to :aceman from comment #4)
> Jcranmer, do you know anything about these JS constructs?

I can't answer these questions, you'd have to ask JS engine folk.
Flags: needinfo?(Pidgeot18)
(Assignee)

Updated

2 years ago
Attachment #8649336 - Flags: review?(mkmelin+mozilla)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)

Comment 9

2 years ago
Comment on attachment 8649336 [details] [diff] [review]
patch

Review of attachment 8649336 [details] [diff] [review]:
-----------------------------------------------------------------

I don't know why it broke either, but your new code is more readable. r=mkmelin
Attachment #8649336 - Flags: review?(mkmelin+mozilla) → review+
(Assignee)

Comment 10

2 years ago
Thanks, I think so too.
Keywords: checkin-needed
(Assignee)

Comment 11

2 years ago
Aryx, can you please push this to try server so we see if it fixes all the about-support.js tests? Otherwise we'd need to file a new bug for the remaining parts. It looks like at least linux builds file.
Flags: needinfo?(aryx.bugmail)
Pushed as https://treeherder.mozilla.org/#/jobs?repo=try-comm-central&revision=9af8c4ba07d1
Flags: needinfo?(aryx.bugmail)

Updated

2 years ago
Duplicate of this bug: 1200012

Comment 14

2 years ago
https://hg.mozilla.org/comm-central/rev/35d8f81ac1527a21d467be69cd293772a7a13c4e
Bug 1195337 - Fix undefined smtp variable by rewriting some array generators in about:troubleshooting. r=mkmelin a=bustage-fix on CLOSED TREE

Updated

2 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 43.0
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1201391
You need to log in before you can comment on or make changes to this bug.