Allow uninstalling add-ons from Marketplace

RESOLVED WONTFIX

Status

Marketplace
General
P4
enhancement
RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: armenzg, Unassigned)

Tracking

({foxfood})

foxfood
Points:
---

Details

(Whiteboard: [bzlite])

(Reporter)

Description

3 years ago
User-Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

I want to remove and add on installed from the hacerplcae and I can't.
In general, I can't uninstall any installed add on.
Hey Michael, 

Can you please help out Armen here?

Thanks
QA Whiteboard: [foxfood-triage]
Flags: needinfo?(mhenretty)
Keywords: qawanted
(Reporter)

Comment 2

3 years ago
In the mailing list I was told to go through settings --> addons to remove them.

However, I had expected to be able to do some from the Hackerplace since it is there where I installed the add-ons to begin with. I never thought I would need to go to the settings app.
Armen, were you able to remove you add-ons using settings? If so, I think this is more of a feature request for marketplace, which we are killing hackerplace in favor of for add-ons in 2.5.
Flags: needinfo?(mhenretty) → needinfo?(armenzg)
(Reporter)

Comment 4

3 years ago
Yes, I was able to through the settings app.
Flags: needinfo?(armenzg)
Confirmed the bug and findings at comment 4. All configurations for Add-ons installed from Hackerplace app sits at Settings > Add-ons page.

This sounds more like a feature request for Hackerplace app to implement configurations on add-ons installed via the app.


Off topic: None of the add-ons worked for me though. Tried rebooting and still don't see them being activated.

Tested on:
Device: Aries 2.5
BuildID: 20150819130905
Gaia: 8f77edf3ac39d36f6df0f5517223d3ed35ed89e0
Gecko: d590b9601ba8138b621b2553daefd8823ab4295a
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0
QA Whiteboard: [foxfood-triage] → [foxfood-triage], [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: qawanted
QA Whiteboard: [foxfood-triage], [QAnalyst-Triage?] → [foxfood-triage], [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
Redirecting over to marketplace then. I don't think we can include this for 2.5, but let's keep this bug here to track it.
Component: Gaia::Feedback → General
Product: Firefox OS → Marketplace
Summary: I can't uninstall addons → Allow unintalling add-ons from Marketplace
Version: unspecified → 1.0
IIRC, the uninstalls in 2.5+ should be coming from FxOS settings. If this is intended to be a request to allow that functionality from within Marketplace... I wonder if the audience should be more broad for this discussion.
Summary: Allow unintalling add-ons from Marketplace → Allow uninstalling add-ons from Marketplace

Updated

3 years ago
Blocks: 1195470

Updated

3 years ago
Flags: needinfo?(mhenretty)
What's the ni? for?
Flags: needinfo?(mhenretty) → needinfo?(ddurst)
I think it was clarification on the nature of this bug. I think it's this:

> This sounds more like a feature request for Hackerplace 
> app to implement configurations on add-ons installed via the app.

If that's the case, then we can s/Hacker/Market/ and I get it.
Severity: normal → enhancement
Flags: needinfo?(ddurst)
Priority: -- → P4
Note that currently, the only API to uninstall an app/addon is through navigator.mozApps.mgmt.uninstall(), which is limited to certified apps. Marketplace, being only a privileged app, does not have access to that API.
(Reporter)

Comment 11

3 years ago
Can we send users from the Hackerplace to "Settings -> addons" to uninstall add-ons? (Since the Hackerplace is not a privileged app)

We can't install addons from the Marketplace, can we? (Since I see Marketplace and Hackerplace used interchangeably in this bug)
Hackerplace should soon be replaced by Marketplace for the source of Add-ons, that's why the bug has been moved there.
mass-flag feature-b2g
feature-b2g: --- → 2.5+

Updated

3 years ago
feature-b2g: 2.5+ → ---

Comment 14

3 years ago
And Marketplace doesn't function as a Consumer Mgmt Portal (at least not for now) where a user can go to marketplace.firefox.com being logged in and see what apps/add-ons/etc. has been installed and where, nor able to remotely uninstalled/remove content nor being able to send it..

But if IoT comes in place - with watches and TV and other devices where on-device management is tricky of various reasons, maybe Marketplace would need to become that management portal

However, managing Add-ons is done from the device: Settings -> Addons where addons can be disabled and deleted and Add-ons can be discovered (links to the add-on catalogue in Marketplace)
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.