Closed Bug 1195401 Opened 6 years ago Closed 6 years ago

Assertion failure while playing a video on Fennec (Preferences accessed off-main-thread)

Categories

(Firefox for Android Graveyard :: Audio/Video, defect)

ARM
Android
defect
Not set
normal

Tracking

(firefox43 fixed)

RESOLVED FIXED
Firefox 43
Tracking Status
firefox43 --- fixed

People

(Reporter: kats, Assigned: kats)

References

Details

Attachments

(2 files)

Attached file GDB backtrace
Fennec build from latest m-c plus unrelated local patches. I got a crash in a debug build upon opening a video. It was reproducible so I attached gdb and got the attached stack.
OS: Unspecified → Android
Hardware: Unspecified → ARM
Version: unspecified → Trunk
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1183788
Since bug 1183788 seems to about doing some optimization work in addition to fixing the crash, I'm reopening this since there's a simple fix for the crash.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Attached patch PatchSplinter Review
Assignee: nobody → bugmail.mozilla
Attachment #8651054 - Flags: review?(snorp)
Product: Core → Firefox for Android
Attachment #8651054 - Flags: review?(snorp) → review+
https://hg.mozilla.org/mozilla-central/rev/8e84bc532965
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 43
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.