Double-clicking the space between two words no longer selects both words

RESOLVED INVALID

Status

()

RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: cpeterson, Unassigned)

Tracking

({regression})

unspecified
Unspecified
Mac OS X
regression
Points:
---

Firefox Tracking Flags

(firefox42 unaffected, firefox43 affected)

Details

(Reporter)

Description

3 years ago
Double-clicking the space between two words no longer selects both wordsI bisected this regression to this mozilla-central pushlog:

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=0876695d1abdeb363a780bda8b6cc84f20ba51c9&tochange=a6eeb28458fd2652e12e57334f046b7776d75bb4

As one of those people who likes to obsessively click and select text when reading, this regression makes me sad. :(
Flags: needinfo?
(Reporter)

Comment 1

3 years ago
I'm now having trouble consistently reproducing this word selection problem. It seems to be correlated with the "Findbar Tweak" extension in my default user profile, but not when I install Findbar Tweak in a new profile.

https://addons.mozilla.org/en-US/firefox/addon/findbar-tweak/
Flags: needinfo?

Comment 2

3 years ago
Have you been changed layout word_select.eat_space_to_next_word in about:config?
Flags: needinfo?(cpeterson)
(Reporter)

Comment 3

3 years ago
Thanks, Alice! Changing the layout.word_select.eat_space_to_next_word pref to false fixes the problem.

For some reason, my default user profile thinks layout.word_select.eat_space_to_next_word's default value is true but a clean profile shows the expected default value false (for OS X). This problem no longer sounds like a word selection regression, but I don't know why my profile (sync'd to another Mac and Firefox for iOS) thinks the default value for layout.word_select.eat_space_to_next_word should be true. I may have sync'd Firefox running in a Windows VM when I was testing recently. The default pref value is true on Windows, so maybe Windows "polluted" my sync prefs?

https://mxr.mozilla.org/mozilla-central/source/modules/libpref/init/all.js#2178
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(cpeterson)
Resolution: --- → INVALID
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.