CTRL-K doesn't work if inside awesome bar

RESOLVED DUPLICATE of bug 1176929

Status

()

Core
Widget: Gtk
RESOLVED DUPLICATE of bug 1176929
3 years ago
3 years ago

People

(Reporter: imphil, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox43 affected)

Details

(Reporter)

Description

3 years ago
In the current nightly (build 20150817061040) I get the following STR:

- focus the awesome bar (or press CTRL-L)
- press CTRL-K

old behavior:
- the search box would get input focus

current behavior:
- the awesome bar remains focused

CTRL-K works as expected if the web content is focussed. So I'd guess the location bar cancels the keyboard event somehow?

I don't have an exact regression range, but it must have happened in the last couple nightlies.
(Reporter)

Comment 1

3 years ago
> I don't have an exact regression range, but it must have happened in the last couple nightlies.

Looks like my feeling was pretty wrong :(

Regression range is: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=1ee54e043b9b&tochange=939320b957c5

So that's the Gtk3 switch.
Blocks: 1186003
Component: Keyboard Navigation → Widget: Gtk
Product: Firefox → Core
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1176929
You need to log in before you can comment on or make changes to this bug.