Closed Bug 1195664 Opened 4 years ago Closed 4 years ago

Error in Service worker, but Warning in client JS: "mutating the [[Prototype]] of an object will cause your code to run very slowly;"

Categories

(Core :: DOM: Service Workers, defect)

42 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1187470

People

(Reporter: arjungadhia, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/45.0.2454.15 Safari/537.36

Steps to reproduce:

Simplified test case set up here: https://adgad.github.io/service-worker-mutation-error/
In actual production code setting the __proto__ comes from babel, so not trivial to replace.

1) Visit https://adgad.github.io/service-worker-mutation-error/ in Firefox Developer edition (v42)



Actual results:

Same code gives a warning in the client side code, but an error in the service worker code.

mutating the [[Prototype]] of an object will cause your code to run very slowly; instead create the object with the correct initial [[Prototype]] value using Object.create client.js:11:1

Error: : mutating the [[Prototype]] of an object will cause your code to run very slowly; instead create the object with the correct initial [[Prototype]] value using Object.create


Expected results:

Expected a warning in both, and the worker code to continue executing.
Please try nightly 43.  I believe this has been fixed in bug 1187470.
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1187470
You need to log in before you can comment on or make changes to this bug.