Crash when adding a contact in Firefox Hello with debug build

RESOLVED FIXED in Firefox 43

Status

()

Core
DOM: IndexedDB
P1
blocker
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: mikedeboer, Assigned: khuey)

Tracking

Trunk
mozilla43
Points:
---

Firefox Tracking Flags

(firefox43 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
STR:

 - Open NightlyDebug from the console (I'm on OSX, currently)
 - Open Firefox Hello by clicking the toolbar icon and make sure you're logged in with your Firefox Account
 - Go to the Contacts tab inside the Hello panel and click the 'New Contact' button.
 - Fill in the 'Name' and 'Email' fields (I used 'Test' and 'info@test.com' respectively)
 - Hit the 'Add Contact' button...

BOOM! (see crash signature field for more info).
(Reporter)

Comment 1

3 years ago
This is also happens when I follow these STR with a *blank* profile:

 - Follow steps 1 - 3 of the STR mentioned in comment 0.
 - Click the 'Use Profile Icons' button.
Crashes in mozilla::CycleCollectedJSRuntime::RunInMetastableState, and indexedDB-related. Either way you slice it, it's probably for Kyle.
Flags: needinfo?(khuey)
FWIW, I reproduced this by modifying the testcase in bug 1170484 slightly to stash the mutation event in a property 'm' on the window, and then accessing m.length in the web console afterwards.
Can someone attach a soccorro report (or gdb backtrace) so I can see the stack in a useful manner?  I need a stack that goes all the way to XRE_main.
Flags: needinfo?(mdeboer)
Flags: needinfo?(khuey)
Flags: needinfo?(bobbyholley)
Created attachment 8649589 [details]
stack.txt
Flags: needinfo?(mdeboer)
Flags: needinfo?(bobbyholley)
(This was in a non-e10s window of an e10s instance. Happened for e10s too, but I figured the non-e10s case would be easier to look at)
Thanks.  This is interesting, it looks like the Mac native event loop works differently than the other platforms.  I may have to relax the assertion.
Assignee: nobody → khuey
Crash Signature: Assertion failure: data.mRecursionDepth > mBaseRecursionDepth, at /Users/mikedeboer/Projects/fx-team/xpcom/base/CycleCollectedJSRuntime.cpp:1141 #01: mozilla::dom::indexedDB::IDBDatabase::Transaction(mozilla::dom::StringOrStringSequence const&, mo…
Duplicate of this bug: 1197188
Since mac can execute events from outside nsThread, I just removed the assertion on mac.
https://hg.mozilla.org/mozilla-central/rev/d21781bad98b
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox43: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla43
You need to log in before you can comment on or make changes to this bug.