Closed Bug 1195761 Opened 5 years ago Closed 5 years ago

Unity Web Player game is not downloaded with dom.ipc.plugins.asyncInit true

Categories

(Core :: Plug-ins, defect)

41 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1194600
Tracking Status
firefox40 --- disabled
firefox41 + verified
firefox42 + verified
firefox43 + fixed

People

(Reporter: phorea, Unassigned)

References

()

Details

(Keywords: regression)

Reproducible with Firefox 41 beta 2 (20150817163452) under Win 7 64-bit and Mac OS X 10.10.5.
Not reproducible with latest Dev Edition 42.0a2 and Nightly 43.0a1 2015-08-18

Steps to reproduce:
Pref dom.ipc.plugins.asyncInit is set to true by default
1. Install Unity Player - https://unity3d.com/webplayer
2. Open http://www.games.jocuri-unity3d.com/200mph-thunder-road-unity-3d.html
3. Restart the browser and reload the game

Expected results:
The game is downloaded and loaded each time the browser is restarted

Actual results:
After the browser is restarted, the game is not downloaded. The error "Failed to download data file" is shown: http://i.imgur.com/YfDCmAx.png
Setting the pref dom.ipc.plugins.asyncInit to false no longer shows the issue.

Note: This also reproduces with Firefox 40 beta 8 so it's not a recent regression.
[Tracking Requested - why for this release]:
Another reproducible issue with async plugin init.
No longer blocks: asyncplugininit
The issue is also reproducible in recently released v40.0.2 (see https://bugzilla.mozilla.org/show_bug.cgi?id=1195758)
I could be wrong but I think this behavior is intentional. See bug 1196000.

Aaron, is this a real issue? Or is this by design based on the fix for above mentioned bug.
Flags: needinfo?(aklotz)
This is definitely a legit issue.
Flags: needinfo?(aklotz)
We should verify that this is fixed in the next 41 beta.
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: qe-verify+
Resolution: --- → DUPLICATE
Duplicate of bug: 1194600
(In reply to Aaron Klotz [:aklotz] (please use needinfo) from comment #6)
> We should verify that this is fixed in the next 41 beta.

Florin, can your team take a look at that?
Flags: needinfo?(florin.mezei)
Yes, we intend to verify all bugs blocking bug 1195607, and close those fixed by bug 1194600. We'll see if we can start today or next week.
Flags: needinfo?(florin.mezei)
Verified that the game is loaded with Firefox 41 beta 5 and Dev Edition 42.0a2.
You need to log in before you can comment on or make changes to this bug.