Desktop games are displayed on mobile devices and "Open website" button is active

RESOLVED INVALID

Status

RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: vcarciu, Assigned: kngo)

Tracking

Avenir
2015-08-18
Points:
---

Details

(Reporter)

Description

3 years ago
Prerequisites:
Android device(Nexus, 5.1.1), Latest Nightly installed

Steps to reproduce:
1. Open marketplace on your device
2. Navigate to the games category
3. Filter to show only websites
4. Filter to show everything for all platforms

Expected results:
Desktop games are not listed

Actual results:
Desktop games are listed. If we open a desktop game to its details page, we will have a "not available for your platform" message, which is correct, but the "Open website" button is active and we can open the games

Please see screencast for a desktop game opened on Android: http://screencast.com/t/hiunS9nyo5UH
(Assignee)

Updated

3 years ago
Assignee: nobody → kngo
https://github.com/mozilla/fireplace/commit/f4b3695b35afed6da591918574e639ea729bc85f
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Reporter)

Comment 2

3 years ago
Verified as fixed. "Open websites " button is greyed out for all games.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 3

3 years ago
Since I verified it recently , I will re-open it because exactly same issue is now reproducible again on MP-dev and https://marketplace-s3dev.allizom.org/
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 4

3 years ago
Opposite bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1195969
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.