Closed Bug 1195927 Opened 5 years ago Closed 1 year ago

entering fullscreen while the location bar is the focus stops toolbar auto-hide from working

Categories

(Firefox :: General, defect)

40 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1477525
Tracking Status
firefox40 --- affected
firefox41 --- affected
firefox42 --- affected
firefox43 --- affected
firefox-esr31 --- unaffected
firefox-esr38 --- affected
firefox56 --- wontfix
firefox57 --- wontfix
firefox58 --- wontfix
firefox59 --- fix-optional
firefox60 --- fix-optional

People

(Reporter: digitalmacka, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150812163655

Steps to reproduce:

1. Open the newtab page (Ctrl+T)
2. Enter fullscreen mode (F11)


Actual results:

The toolbar won't auto-hide. This happens once per newtab tab, as re-entering fulscreen mode will make auto-hide work again. Repeating the steps will break auto-hide with each fresh newtab tab.


Expected results:

The toolbar should auto-hide
Component: Untriaged → New Tab Page
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64
I think your summary is missing a point.

1) When you press F11, if the focus is already on the webpage, fullscreen mode applies immediately.
2) If you press F11 with the focus in the location or search bar, you have to focus on the webpage to enter fullscreen mode (and hide the bars).

That's the current behavior of fullscreen mode for ages ago.

BUT, I agree with you, there is an issue with the 2nd statement, it doesn't work anymore, and not only with the New tab page, but with every tab. Indeed, refocus on the page doesn't enter fullscreen mode.
STR:
1) Open a new tab
2) focus on location bar
3) press F11
4) focus on New tab page (like the search field inside the tab)

Result: no fullscreen after 2 or 3 sec.

Regression range:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=0e631971b841&tochange=0b81c10a9074
I didn't realise the location bar was the focus whenever the New Tab page is opened. Like you said, the location bar being the focus is the actual reason auto-hide won't work and it happens on any tab with the location bar focused.

STR:
1. While FF is windowed, focus on the location bar in any tab
2. Press F11
3. Focus on the page by clicking on it somewhere

Result: Toolbar won't hide
Component: New Tab Page → Untriaged
Summary: entering fullscreen while the newtab page is the active tab stops toolbar auto-hide from working → entering fullscreen while the location bar is the focus stops toolbar auto-hide from working
Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=e89c06c004f8&tochange=02566635767f

Suspect:
02566635767f	Akshendra Pratap — Bug 515196 - Added padding to toolbar autohide. r=dao
Blocks: 515196
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(akshendra521994)
I do observe this when I was testing fullscreen. cc myself first. Will look into this issue later.
BTW, Alice, could you please cc me in the future if you see any bug relates to fullscreen, so that I can be aware of them as soon as possible.
Tested this on latest Nightly build 45.0a1 using Windows 7 x64 and it still reproduces with the steps mentioned above. Updating product and component.
Component: Untriaged → Event Handling
Product: Firefox → Core
Component: Event Handling → General
Product: Core → Firefox
// Huh, just used mozregression to find out that it's already filed...
Note that before bug 515196 navigation-toolbox hid only after user moved mouse by several pixels.
Is that really the desired behavior? Imo navigation-toolbox should hide immediately after focus lost:
  1. While FF is windowed, focus on the location bar in any tab
  2. Press F11
  3. Focus on the page by clicking on it somewhere
  4. Toolbars aren't hidden, so move mouse to the toolbars to, idk, handle it somehow
Result:
  Argh, toolbars hide during the mouse movement. Basically it's just distracting unexpected behavior.
Flags: needinfo?(akshendra521994)
Duplicate of this bug: 1403878
Duplicate of this bug: 1424885
This issue seems to reappear every once in a while but it sounds like an edge case.
Duplicate of this bug: 1470665
Duplicate of this bug: 1524388

I suppose this should have been fixed by bug 1477525. Feel free to reopen if it's not.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1477525
You need to log in before you can comment on or make changes to this bug.