Closed Bug 1195998 Opened 5 years ago Closed 5 years ago

Crash in TextureClient::ForceRemove

Categories

(Core :: Graphics, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla43
Tracking Status
firefox42 + fixed
firefox43 + fixed

People

(Reporter: bas.schouten, Assigned: bas.schouten)

References

Details

Attachments

(1 file)

Does this appear like an acceptable fix?
Assignee: nobody → bas
Status: NEW → ASSIGNED
Attachment #8649499 - Flags: review?(nical.bugzilla)
[Tracking Requested - why for this release]: Top 10-crash on Aurora.
Attachment #8649499 - Flags: review?(nical.bugzilla) → review+
https://hg.mozilla.org/mozilla-central/rev/ffde34f25611
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla43
Bas, want to request uplift for this ?
Flags: needinfo?(bas)
Tracking for 42 too.
Milan, I guess we want to uplift that to 42, right? If it is the case, could you fill the uplift request? Thanks
Flags: needinfo?(milan)
Comment on attachment 8649499 [details] [diff] [review]
Don't call force remove for actors which don't have TextureClients associated

Approval Request Comment
[Feature/regressing bug #]:
[User impact if declined]: Top crasher on 42 and 43.
[Describe test coverage new/current, TreeHerder]:
[Risks and why]: Low, a null pointer check.
[String/UUID change made/needed]:
Flags: needinfo?(milan)
Flags: needinfo?(bas)
Attachment #8649499 - Flags: approval-mozilla-aurora?
Comment on attachment 8649499 [details] [diff] [review]
Don't call force remove for actors which don't have TextureClients associated

Thanks Milan. Taking it as it fixes a crash.
Attachment #8649499 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Duplicate of this bug: 1200816
You need to log in before you can comment on or make changes to this bug.