Checking for signed updates aborts if it encounters a single unsigned update

RESOLVED WONTFIX

Status

()

Toolkit
Add-ons Manager
RESOLVED WONTFIX
2 years ago
2 years ago

People

(Reporter: vladan, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox43 affected)

Details

(Reporter)

Description

2 years ago
When updating unsigned addons, the Addon Manager shouldn't give up if it runs into a problem with a SINGLE update.

Longer version:

One of my profiles got the "Unsigned addons" warning after I updated Firefox to a more recent version. The blocked addons in my profile were GeckoProfiler (not AMO)and SendTabToDevice (AMO). Both were unsigned and both had updates available. SendTabToDevice's updated version was signed, GeckoProfiler's was not.

I manually checked for addon updates from the about:addons gear icon, and the update failed while trying to update GeckoProfiler. Presumably this is because the new update was also unsigned.

However, SendTabToDevice had a signed update available, but Firefox didn't try to update it after running into the issue with GeckoProfiler's update.

Note that manually clicking on "Update" for SendTab in about:addons did update it to a signed version correctly.
I've been unable to reproduce this. I downloaded an old build of the gecko profiler and installed it in Nightly. I then got an old build of send to device from AMO, stripped its signing info (since all versions on AMO are signed) and installed that. Then I turned on signing requirements and did an update check from the gear menu. As I'd expect gecko profiler showed an error updating, send to tab updated and enabled itself.

I tried a few more times in different combinations and it worked as I'd expect every time. This isn't too surprising since we update add-ons in parallel. It would be difficult for the state of one to affect another.

Can you still reproduce this? Is there anything you can think of that might be different when you did it?

It's possible this was just a random network issue with the download of send tab to device, maybe a bad CDN, but that does seem unlikely.
Flags: needinfo?(vdjeric)
(Reporter)

Comment 2

2 years ago
The only thing that was different in my test procedure was that I used an older profile (last used with an older version of Firefox that doesn't enforce signing) and Firefox probably updated itself right before it checked for these add-on updates.
Flags: needinfo?(vdjeric)
(Reporter)

Comment 3

2 years ago
actually, it's more likely that it was just an old profile being used with a new version of Firefox for the first time (a new version that enforces signing)

Comment 4

2 years ago
Based on comment 1 and comment 3, I think we can Won't fix, this. If you think that's not the case, please re-open.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.