Badges in a user profile page aren't displayed correctly in some locales

VERIFIED FIXED in 2015-09-03

Status

addons.mozilla.org Graveyard
Public Pages
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: magopian, Assigned: nolski)

Tracking

unspecified
2015-09-03

Details

(Whiteboard: [good first bug], URL)

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8649715 [details]
Screen Shot 2015-08-19 at 09.32.55.png

When using the french localization (and maybe others), the "badges" that display below the photo/avatar on an account profile aren't displayed correctly (see screenshot).

Here's an example url: https://addons.mozilla.org/fr/firefox/user/magopian/
(Assignee)

Comment 1

2 years ago
It looks like the issue is due to the parent div of those tags having a set height and the localization causing an over flow on the line. I'll have a patch submitted shortly.
(Assignee)

Updated

2 years ago
Assignee: nobody → me

Comment 2

2 years ago
Commits pushed to master at https://github.com/mozilla/olympia

https://github.com/mozilla/olympia/commit/aece4689fd09957159d768d3abd90476452b83c1
Modified badge height so longer badges fit (bug 1196141)

https://github.com/mozilla/olympia/commit/91f2e269c20a0bda6d0546c865c4b4371cf0b90d
Merge pull request #708 from Nolski/role-overflow-issue

Modified badge height so longer badges fit (bug 1196141)
(Reporter)

Comment 3

2 years ago
Thanks Mike!
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2015-09-03

Comment 4

2 years ago
Verified as fixed in FF40(Win7)
Tried with fr and other localization and it appears to work well: http://screencast.com/t/eMVVJ40jGSr
Closing bug.
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.