Thunderbird 38.2.0 stops auto retrieving mail after resuming from sleep.

RESOLVED DUPLICATE of bug 1196662

Status

Thunderbird
Untriaged
RESOLVED DUPLICATE of bug 1196662
3 years ago
2 years ago

People

(Reporter: Jim, Unassigned)

Tracking

38 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8649758 [details]
Troubleshooting Information

After updating to Thunderbird 38.2.0, after resuming the computer from sleep mode, Thunderbird stops automatically retrieving messages until I manually check for mail.

I have three email accounts, one POP3 and two IMAP.  The IMAP accounts' new messages used to appear instantly.  The POP3 account is set to retrieve new mail every 10 minutes.

Thunderbird updated to 38.2.0 on Friday and all seemed well.  I don't shut down my computer, I put it to sleep every night.  When I wake it the next day I usually almost immediately hear the new mail notification if I have new mail.  It's not unusual for me not to get a lot of email over the weekend, Saturday went by without a single new message appearing in my inboxes.  There were no new messages when waking it Sunday too.

Sunday afternoon I applied the new Windows Updates and rebooted.  After rebooting and starting Thunderbird, I had dozens of new messages from Saturday and Sunday.

When I woke the computer Monday I once again didn't receive any new messages in my inboxes.  After not receiving any new mail by that afternoon I decided to click the Get All New Messages button and it retrieved several new messages with time stamps well before when I woke the machine.  Again, upon waking the machine Tuesday there were no new messages, so after a few minutes I pressed the Get All New Messages button and there were several new messages.  After manually checking for new messages, it then goes back to automatically retrieving messages until I put the machine to sleep and wake it.

Comment 1

3 years ago
I, too, am running Thunderbird 38.2.0.  With TB open, I closed the lid on my laptop and left to run some errands.  When I returned after an hour and opened the lid on my laptop, it came out of sleep mode.  TB did not check for any new messages on the server and parts of the UI were inoperable, e.g. vertical scroll bars.  I opened the Address Book, but its behaviour was sluggish and erratic.  

The Get Messages command is inoperable, but the down arrow command to the right accepts mouse clicks. However, the drop down menu items don't initiate a connection to the server.

The only way I could clear the problem was to terminate TB, and then in Windows Task Manager, kill the TB process.

Comment 2

2 years ago
Running Thunderbird 38.2.0 on Win7 x64. I have 1 POP3 account using SSL/TLS over port 995, normal password authentication method.  "Check for messages every [10] minutes" is enabled.

Everything works as normal when TB is freshly started.  If at some point the system is put into Windows "sleep mode", upon waking TB no longer seems to check for mails every [10] minutes.  Also, nothing shows in the Activity Manager, normally a message such as "No messages to download" appears at the specified interval but this is not the case for this failure mode.  Exiting the software and re-opening it resumes normal operation.

I haven't tested hibernation mode but it could be related:
Bug 1195043
Bug 1197515
> Bug Summary : Thunderbird 38.2.0 stops auto retrieving mail after resuming from sleep.
(In reply to Jim from comment #0)
> I have three email accounts, one POP3 and two IMAP.

Your problem may be bug 1196662 if your problem started to occur from Tb 38.2.0.
  bug 1196662 : Regression by Tb 38.2.0.
  problem looks resolved by patch for Bug 1182831(typo in autosync.js) and autosync is feature for imap.
See also bugs in dependency tree for bug 1196662.

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1196662
You need to log in before you can comment on or make changes to this bug.