Closed Bug 1196177 Opened 6 years ago Closed 6 years ago

Launch Camera from Gallery, but Camera can not work if you repeatly tap Home key to exit while Camera is lauching.

Categories

(Firefox OS Graveyard :: Gaia::Gallery, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:2.5+, b2g-v2.2 unaffected, b2g-master verified)

VERIFIED FIXED
FxOS-S9 (16Oct)
blocking-b2g 2.5+
Tracking Status
b2g-v2.2 --- unaffected
b2g-master --- verified

People

(Reporter: huxiaoyan, Assigned: aosmond)

References

Details

(Keywords: regression, Whiteboard: [2.5-aries-test-run-1])

Attachments

(5 files)

[1.Description]:
[Aries kk v2.5][Flame kk v2.5][Gallery]While Camera is lauching, quickly tap Home key to exit. Repeat that for several times, then launch Camera from Gallery. It can not work unless you restart device.

Found time:03:08
See attachment: logcat_0308.txt & Aries _kk_v2.5.3gp
[2.Testing Steps]: 
Premise: There  are some picture in Gallery.
1.Launch Camera and immediately tap Home button to exit while it is launching.
2.Repeat it 5 or 6 times.
3.Launch Gallery  and tap Camera icon

[3.Expected Result]: 
3.The camera view finder is normal, and user can take phone or record video.

[4.Actual Result]: 
3.The camera view finder is black or blank, and user can not take phone or record video.

[5.Reproduction build]: 
Device: Aries KK 2.5(Affected)
Build ID               20150818005621
Gaia Revision          60489c1ff8c5d1633fc4837d4f8019623d4e1940
Gaia Date              2015-08-16 02:21:48
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/6ae3e9ff53b2bae8d95a90c9f25368fd81fa357e
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150818.003312
Firmware Date          Tue Aug 18 00:33:21 UTC 2015
Bootloader             s1

Device: Flame KK 2.5(Affected)
Build ID               20150818150207
Gaia Revision          507ba38fb64b27f87d11f4104dfcc58448e12b1a
Gaia Date              2015-08-18 10:50:12
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/2c272af993c23e803f6ea7798a812b0c8abfad4d
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150818.184156
Firmware Date          Tue Aug 18 18:42:07 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Flame KK 2.2(Unaffected)
Build ID               20150818032504
Gaia Revision          335cd8e79c20f8d8e93a6efc9b97cc0ec17b5a46
Gaia Date              2015-08-14 19:06:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/c29970d16372
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150818.065127
Firmware Date          Tue Aug 18 06:51:38 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0



[6.Reproduction Frequency]: 
occasionally Recurrence,3/5

[7.TCID]: 
Free Test

[8.Note] This  bug  always happens on the device where Camera is launched for first time.
ni?ing aosmond.  Wasn't there a fix that you were implmenting against button mashing?
Flags: needinfo?(aosmond)
Summary: Gallery] Launch Camera from Gallery, but Camera can not work if you repeatly tap Home key to exit while Camera is lauching. → Launch Camera from Gallery, but Camera can not work if you repeatly tap Home key to exit while Camera is lauching.
I can't repro this on today's nightly.  adding qawanted to double check (for me from 3rd or 4th start of the app, it instantly switches to the viewfinder mode)
Keywords: qawanted
(In reply to No-Jun Park [:njpark] from comment #2)
> ni?ing aosmond.  Wasn't there a fix that you were implmenting against button
> mashing?

Not for the home screen button. That might be challenging.(In reply to No-Jun Park [:njpark] from comment #3)
> I can't repro this on today's nightly.  adding qawanted to double check (for
> me from 3rd or 4th start of the app, it instantly switches to the viewfinder
> mode)

ni me again if it can be reproduced.
Flags: needinfo?(aosmond)
Hi Andrew,

    I can repro on latest Flame KK v2.5 and Aries KK v2.5. The key of this bug is that user should quickly tap Home button to exit before the camera view finder is opened, and repeat this operation for at least 5 or 6 times.

    Could you please take a look at this?

Thank you very much.


---------------------------------------------------------------------------------------------

Actual results: The camera view finder is black, and user can not take photo or record video.
See attachments: logcat_1511.txt and Aries_KK_v2.5.3gp.
Reproduce rate: 5/10


Device: Aries KK 2.5(Affected)
Build ID               20150923233246
Gaia Revision          8472f0c736660072799aaae60e4b6001a6aaceb4
Gaia Date              2015-09-23 10:29:02
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/f1dffc8682fbba463cb4bb305f293ddcccbc20b4
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150923.225204
Firmware Date          Wed Sep 23 22:52:12 UTC 2015
Bootloader             s1

Device: Flame KK 2.5(Affected)
Build ID               20150923150203
Gaia Revision          8472f0c736660072799aaae60e4b6001a6aaceb4
Gaia Date              2015-09-23 10:29:02
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/4a46de29431baa621d98d8f1168e43297ce1a916
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150923.184655
Firmware Date          Wed Sep 23 18:47:17 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0
QA Whiteboard: [MGSEI-Triage+]
Flags: needinfo?(aosmond)
Keywords: qawanted
Attached video Aries_KK_v2.5.3gp
Attached file logcat_1511.txt
Huh. There are a few problems actually. We seem to be missing battery status updates (which means the camera controller thinks we are stuck on a low battery) and sometimes the mozCamera object doesn't exist when the zoom bar controller is lazily loaded (causing a JS error and stopping any more loading).
Assignee: nobody → aosmond
Status: NEW → ASSIGNED
Flags: needinfo?(aosmond)
Attachment #8665378 - Flags: review?(jdarcangelo)
Bug 1189105 introduced the zoom related regression.
Blocks: 1189105
Duplicate of this bug: 1208266
[Blocking Requested - why for this release]:

This is worse in current builds. It does not require button mashing. The user only has to press home while the camera is launching.
blocking-b2g: --- → 2.5?
QA Whiteboard: [MGSEI-Triage+] → [MGSEI-Triage+][QAnalyst-Triage+]
blocking-b2g: 2.5? → 2.5+
Priority: -- → P2
Attachment #8665378 - Flags: review?(jdarcangelo) → review+
Keywords: checkin-needed
Blocks: 1210849
https://github.com/mozilla-b2g/gaia/commit/1e8a5b0c80bbd7a19fde183c1b1a17a752624bbf
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → FxOS-S9 (16Oct)
This issue is verified fixed on the latest Aries and Flame 2.5 master build.
Camera continues to work properly after repeatedly tapping the Home button right when opening the camera app. I used the STR in Comment 1, as well as the STR in comment 1 as well as the STR from bug 1208266.

Environmental Variables:
Device: Aries 2.5
Build ID: 20151009104251
Gaia: 1609aecaba381c14eff95d5084e59280f53b7d8b
Gecko: d01dd42e654b8735d86f9e7c723cc869a3b56798
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 44.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Environmental Variables:
Device: Flame 2.5
BuildID: 20151009030234
Gaia: 1609aecaba381c14eff95d5084e59280f53b7d8b
Gecko: d01dd42e654b8735d86f9e7c723cc869a3b56798
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 44.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [MGSEI-Triage+][QAnalyst-Triage+] → [MGSEI-Triage+][QAnalyst-Triage?]
Flags: needinfo?(jmercado)
QA Whiteboard: [MGSEI-Triage+][QAnalyst-Triage?] → [MGSEI-Triage+][QAnalyst-Triage+]
Flags: needinfo?(jmercado)
You need to log in before you can comment on or make changes to this bug.