Closed Bug 1196206 Opened 4 years ago Closed 4 years ago

The reftest fwid-spaces.html is dependent on the Meiryo font, which is not present on Win10

Categories

(Core :: Layout: Text and Fonts, defect)

Unspecified
Windows 10
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla43
Tracking Status
firefox43 --- fixed

People

(Reporter: jfkthame, Assigned: jfkthame)

References

Details

Attachments

(2 files)

This test requires a font with 'fwid' feature support, and specifies Meiryo for Windows. But on Win10, Meiryo isn't available and so the test fails; the fallback it uses doesn't support the 'fwid' feature.

We should be able to fix this by adding Win10's Yu Gothic as an alternative in the font-family list.
Assignee: nobody → jfkthame
Status: NEW → ASSIGNED
(In reply to Jonathan Kew (:jfkthame) from comment #0)
> This test requires a font with 'fwid' feature support, and specifies Meiryo
> for Windows. But on Win10, Meiryo isn't available and so the test fails; the
> fallback it uses doesn't support the 'fwid' feature.

Um, really?!? Which install of Windows 10 are you using? JA locale installs naturally include it, as did the English preview install. I think it's fine to add Yu Gothic but I just want to be sure we're not testing Windows 10 vertical support in an oddly configured environment.
(In reply to John Daggett (:jtd) from comment #2)
> (In reply to Jonathan Kew (:jfkthame) from comment #0)
> > This test requires a font with 'fwid' feature support, and specifies Meiryo
> > for Windows. But on Win10, Meiryo isn't available and so the test fails; the
> > fallback it uses doesn't support the 'fwid' feature.
> 
> Um, really?!? Which install of Windows 10 are you using? 

A basic en-US install, AIUI. (This isn't me; ask :Callek if you want more info on the machine.)

> JA locale installs
> naturally include it, as did the English preview install. I think it's fine
> to add Yu Gothic but I just want to be sure we're not testing Windows 10
> vertical support in an oddly configured environment.

This is the cause of one of the reftest failures in https://bugzilla.mozilla.org/show_bug.cgi?id=1193447. Looking at the failure, it's clear the font being used lacks 'fwid' support, so I asked him to check whether Meiryo was present on the system, and he said it wasn't. Maybe it's part of some optional component of the installation?

(This is nothing to do with vertical support, btw.)
Justin, are these machines using a generic Windows 10 install or some sort of pared-down "lightweight" install? If you could run with fontlist logging enabled and attach the output, that would be really useful.

  NSPR_LOG_FILE=/path/to/fontlist.txt
  NSPR_LOG_MODULES=fontlist:5

Thanks!
Flags: needinfo?(bugspam.Callek)
Comment on attachment 8649814 [details] [diff] [review]
Add Windows 10 font Yu Gothic to the font list in fwid-spaces.html

Review of attachment 8649814 [details] [diff] [review]:
-----------------------------------------------------------------

No problem with this but I would like to make sure we're using a Windows 10 environment that has a set of fonts that are close to what an actual user would experience. Another example of where I think we should be running tests in multiple locales.
Attachment #8649814 - Flags: review?(jdaggett) → review+
John, I'm happy to run (on try) with that NSPR logging if you desire, however...

This was a win10 "final" release of en-US locale. I used "Character Map" on our win10 system to check what fonts were installed and Meiryo was not. (I also just now double checked on my local VM of win10, which I installed myself, and its also not there)

I also found, https://social.technet.microsoft.com/Forums/en-US/b91e5716-eba2-4933-ab67-5a723156175b/fonts-in-windows-10, just now. An excerpt is below:

"""
In Windows 8.1, the Meiryo UI font family was used for Japanese text in the Windows user interface. On Windows Phone 8.1, the popular Yu Gothic font was used for Japanese. In Windows 10, the user interface font family for Japanese has changed to Yu Gothic UI for all editions. In order to make Yu Gothic UI perform as intended in Windows UI, Yu Gothic UI is adapted from Yu Gothic with certain metric and character width modifications as well as alternate glyphs for Latin characters. For non-UI content, the Yu Gothic fonts are still included. For optimal readability, the OpenType “palt” feature (proportional alternate widths) should be enabled for text formatted with Yu Gothic.
"""

If you require me to run with the NSPR logging, I'm happy to, just re-needinfo me so I know the descriptions I found are not enough to satisfy.
Flags: needinfo?(bugspam.Callek) → needinfo?(jdaggett)
url:        https://hg.mozilla.org/integration/mozilla-inbound/rev/8e5f26d46547ae88b8adb472b0a7fae300925bdb
changeset:  8e5f26d46547ae88b8adb472b0a7fae300925bdb
user:       Jonathan Kew <jkew@mozilla.com>
date:       Thu Aug 20 15:52:40 2015 +0100
description:
Bug 1196206 - Add Windows 10 font Yu Gothic to the font list in fwid-spaces.html. r=jdaggett.
https://hg.mozilla.org/mozilla-central/rev/8e5f26d46547
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla43
(In reply to Justin Wood (:Callek) from comment #6)

> If you require me to run with the NSPR logging, I'm happy to, just
> re-needinfo me so I know the descriptions I found are not enough to satisfy.

Interesting. Looks like Windows 10 moved to a "install on use" model. The logging info would still be helpful, thanks (see comment 4).
Flags: needinfo?(jdaggett) → needinfo?(bugspam.Callek)
(In reply to John Daggett (:jtd) from comment #9)
> (In reply to Justin Wood (:Callek) from comment #6)
> 
> > If you require me to run with the NSPR logging, I'm happy to, just
> > re-needinfo me so I know the descriptions I found are not enough to satisfy.
> 
> Interesting. Looks like Windows 10 moved to a "install on use" model. The
> logging info would still be helpful, thanks (see comment 4).

I threw a patch up that should have given these logs, at least in opt it didn't seem to. I'm enlisting ATeam for help...
https://treeherder.mozilla.org/#/jobs?repo=try&revision=eff1a0b35af1

Leaving n-i so I can try and get you those logs as a reminder if I get tied up.
(In reply to John Daggett (:jtd) from comment #9)
> (In reply to Justin Wood (:Callek) from comment #6)
> 
> > If you require me to run with the NSPR logging, I'm happy to, just
> > re-needinfo me so I know the descriptions I found are not enough to satisfy.
> 
> Interesting. Looks like Windows 10 moved to a "install on use" model. The
> logging info would still be helpful, thanks (see comment 4).

OK I finally have results!

https://treeherder.mozilla.org/#/jobs?repo=try&revision=52a1491882fa&group_state=expanded

Specifically that push (*) Made sure the NSPR logs were available and uploaded and (*) backed out this bugs patch for potentially easier identification.

For https://treeherder.mozilla.org/logviewer.html#?job_id=10874431&repo=try the w10 Debug reftest results, the NSPR log is zipped up and stored in http://mozilla-releng-blobs.s3.amazonaws.com/blobs/try/sha512/9d04a78f3726d46fa2672fd39d67c850a045b4b64edb84915b1b474b2f555b9a3213d397e075300c4228bb52b0b4b804351b69e1028cf54bb45d073d2b78d571  for your convenience

:jtd, is there a spinoff bug needed, or any other news?
Flags: needinfo?(bugspam.Callek) → needinfo?(jdaggett)
Thanks Justin!

I'm guessing you're looking for someone to tackle the reftest failures in the logfiles! Sure, file new bugs for any you can't immediately fix.

I'll file a separate bug to update pref font lists for Windows 10.
Flags: needinfo?(jdaggett)
You need to log in before you can comment on or make changes to this bug.