Closed Bug 1196214 Opened 6 years ago Closed 6 years ago

Toggling passcode lock off then on permanently locks user out of phone

Categories

(Firefox OS Graveyard :: Gaia::System::Lockscreen, defect)

All
Other
defect
Not set
normal

Tracking

(blocking-b2g:2.5+)

RESOLVED WORKSFORME
blocking-b2g 2.5+

People

(Reporter: callahad, Unassigned)

References

()

Details

(Keywords: foxfood)

>> Feature Request Summary:
Toggling passcode lock off then on permanently locks user out of phone

>> Description of feature, or problem to be solved
I disabled my PIN lock for a presentation. After the presentation, I re-enabled it. The phone then completely refused to unlock, barring me from accessing my device.

STR:

1. Set a Passcode Lock several OTA's ago
2. Update to latest foxfood OTA
3. Disable and re-enable Settings -> Screen Lock -> Passcode Lock
4. Turn off device, wait for timeout, attempt to unlock device

Expected Results:

1. The lock screen accepts my PIN from step 3.

Actual Results:

1. My PIN was rejected.
2. The PIN "0000" was also rejected.

Workaround (destroys settings, preserves app data; requires prior adb setup):

    adb shell
    su
    cd /data/local/storage/permanent/chrome/idb
    rm -r 2588645841ssegtnti.*
    start b2g

If I hadn't set up my phone for debugging via ADB, I would have had to completely re-flash, losing all of my SMSs and other data.

>> Mailing list thread
https://groups.google.com/a/mozilla.com/forum/#!topic/foxfood/v6j4g51kJcg
The issue persisted across reboots; the PIN was not recognized or accepted.
[Blocking Requested - why for this release]:

Irrecoverable data loss on devices without an adb root shell.

Similar to Bug 1175910, but PIN "0000" is not accepted. Previously experienced back in 2015-06 on Bug 1176374.
blocking-b2g: --- → 2.5?
Kevin, 

Can you get this tested please. Need to block if its reproduced. 

Thanks
Keywords: qawanted
I cannot reproduce this issue. I flashed to Aries RC4 build, followed STR, OTA'ed to dogfood-latest, followed STR, and lockscreen was correctly enabled and it accepted my passcode and unlocked without issue.

Device: Aries
BuildID: 20150821164641
Gaia: f6cde6b8a2af2d2cfa3ce9b7f4cda2daab9174a8
Gecko: 22c34579ae0720e7d3dc39a22b9d33f13bc0198b
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5 Master) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0
Flags: needinfo?(jmercado)
Flags: needinfo?(jmercado)
I am also unable to reproduce this issue.  I attempted this when running an OTA from the RC4 build on the dogfood update channel.  I tried several different variations of enabling and disabling the lockscreen before and after device reboots, both before and after running the OTA.  The passcode always unlocked the device properly.
Leaving qawanted for another tester to attempt.

Environmental Variables:
Device: Aries 2.5
BuildID: 20150812231434
Gaia: 52f3ea58df38e5427f6afeb636bc6ad01d24022f
Gecko: 7649ffe28b67aa2dad0f67ea01500c0ff91b2bac
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0
Flags: needinfo?(jmercado)
Flags: needinfo?(jmercado)
I was unable to reproduce this issue.  While attempting to reproduce the bug, I OTA updated from RC4->Dogfood->Dogfood-Latest.  I utilized the STR in comment 0, and I also power cycled the phone with the passcode enabled/disabled, allowed the device to time out various times, etc.  I never was locked out of the phone and the passcode worked correctly.  

Environmental Variables:
Device: Aries Master
Build ID: 20150824130451
Gaia: d7fb5717d3e0153ac64af2c0d5c11079846d81c3
Gecko: 205427533c567b7b67bf2df3937e851f16204668
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (Master)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: qawanted
Dan can you still reproduce this issue?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado) → needinfo?(dan.callahan)
Keywords: qawanted
Broken functionality. If clear STR can be found. Need a fix.
blocking-b2g: 2.5? → 2.5+
Flags: needinfo?(gweng)
So what you mean to NI me? Expect me to find a STR while others can't do? I don't really understand that, except that you may want me to keep in the task queue.
Flags: needinfo?(gweng) → needinfo?(mpotharaju)
Hey Greg, Sorry for the confusion. Yes, its just to keep you informed of this issue. 

In our 2.5 triage meeting, Christianne mentioned you were working on Lockscreen and requested an NI on you, so you are aware. I cc'ed you on few other Lockscreen issues too, but NI was recommended. 

Thanks
Okay,I got it. Thanks.
I'm also unable to reproduce this on a current build.

I'm really uncomfortable with how many ephemeral bugs I'm running into, but without reliable STR, I don't know what else we can do. :(
Flags: needinfo?(dan.callahan)
Closing this out for now.  Please reopen if it occurs again.
Status: NEW → RESOLVED
Closed: 6 years ago
QA Whiteboard: [QAnalyst-Triage+]
Keywords: qawanted
Resolution: --- → WORKSFORME
Something I just noticed: I previously had my PIN timeout set to 10 minutes, but upon trying to repro, I no longer see that option. I do see 5 minutes and 15 minutes.

I wonder if this might be related to Bug 1036805, which removed several timeout options?
Flags: needinfo?(mpotharaju)
You need to log in before you can comment on or make changes to this bug.