Closed Bug 1196240 Opened 7 years ago Closed 5 years ago

Loading webkinz.com in Firefox 40 with dom.ipc.plugins.asyncInit set to true causes a black screen to show and the browser hangs up for ~30 seconds

Categories

(Core :: Plug-ins, defect)

40 Branch
defect
Not set
normal

Tracking

()

RESOLVED INVALID

People

(Reporter: michaelb, Unassigned)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0
Build ID: 20150817163452

Steps to reproduce:

Ensure dom.ipc.plugins.asyncInit is set to true

Log into webkinz.com (create a free account if necessary)

Observe the browser will hang for ~30 seconds and usually a black screen is shown

Eventually the black screen goes away and the site loads


Actual results:

A black screen is shown and the browser hangs for ~30 seconds


Expected results:

No black screen, no hanging
Attached image black_screen.png
Component: Untriaged → Plug-ins
Version: unspecified → 40 Branch
We should verify that this has been fixed in the next 41 beta.
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Flags: qe-verify+
Resolution: --- → DUPLICATE
Duplicate of bug: 1194600
I didn't reproduce the blank screen with Firefox 41 beta 2, the screen was white for a few seconds and them the game  loaded.
Using Firefox 41 beta 5, the game is directly loaded.

Could you please try with latest beta (https://ftp.mozilla.org/pub/mozilla.org/firefox/candidates/41.0b5-candidates/build1/) and let us know if the issue still occurs? Thank you!
Flags: needinfo?(michaelb)
I've tested this using the latest beta here:
https://ftp.mozilla.org/pub/mozilla.org/firefox/candidates/41.0b6-candidates/build1/win64/en-US/

The issues persists, since the dom.ipc.plugins.asyncInit setting is set to true.

Note that in the latest live patch (40.0.3) the setting has been changed to false, and everything is working fine, but it is broken in the latest beta of 41.
Status: RESOLVED → UNCONFIRMED
Flags: needinfo?(michaelb)
Resolution: DUPLICATE → ---
(In reply to Mike from comment #4)
> The issues persists, since the dom.ipc.plugins.asyncInit setting is set to
> true.

Bug 1194600 should fix this issue and the game should load properly even with the pref set to true.

I managed to reproduced it, but very hard as most of the times, the game area is white for just a few seconds and then the game loads fine.
Only in about 3 of more than 10 attempts I saw the black screen, confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true
How long are you waiting once you see the black? I see the black screen but the Flash content eventually always loads. Note that when I see the black screen, it is taking up to 30 - 40 seconds before the content appears.
Flags: needinfo?(petruta.rasa)
When I see the black screen, it takes around 25-30 seconds for me too until the game is loaded.
Flags: needinfo?(petruta.rasa)
We have observed the same behaviour, the black screen will show, which locks up the browser for 30-40 seconds, and then eventually it will unlock and the Flash content will show.

The white screen shown for ~3 seconds is normal behaviour.
I think that black is some kind of hang on the compositor. I'm trying to narrow it down with the profiler.
This website no longer uses Flash.
Status: NEW → RESOLVED
Closed: 7 years ago5 years ago
Resolution: --- → INCOMPLETE
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---
webkinz.com does still use Flash primarily for gameplay, just not on the home page or login page.  Which was also the case when this ticket was first created.
Async plugin init is a defunct feature that no longer exists.

If there are still problems with Flash on this website then please open a new bug.
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.