Closed Bug 1196290 Opened 5 years ago Closed 5 years ago

[Aries][Lockscreen] Lockscreen can change to landscape orientation

Categories

(Firefox OS Graveyard :: Gaia::System::Lockscreen, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.5+, firefox43 fixed, b2g-master verified)

RESOLVED FIXED
FxOS-S6 (04Sep)
blocking-b2g 2.5+
Tracking Status
firefox43 --- fixed
b2g-master --- verified

People

(Reporter: AdamA, Assigned: wchen)

References

()

Details

(Keywords: regression, Whiteboard: [2.5-Daily-Testing][Spark][Systemsfe])

Attachments

(3 files)

Attached file logcat
Description:
When the user is on the lockscreen they can turn the phone on its side and the phone will change to landscape orientation. when in landscape users are unable to unlock the phone. This issue also is occurring in the FTU/FTE. The user is able to change the phones orientation in all pages of it.

Repro Steps:
1) Update a Aries to 20150819130905
2) Lock the phone
3) Press the lock button so the lockscreen is visible
4) Turn the phone to landscape mode
5) Observe Screen

Actual:
the lockscreen can change to landscape mode

Expected:
It is expected that the lock screen cannot change orientation

Environmental Variables:
Device: Aries 2.5 [Full Flash]
Build ID: 20150819130905
Gaia: 8f77edf3ac39d36f6df0f5517223d3ed35ed89e0
Gecko: d590b9601ba8138b621b2553daefd8823ab4295a
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Repro frequency: 10/10
See attached: video clip(https://youtu.be/5yrBYAXGVVc), logcat
This issue DOES NOT occur on Flame 2.5.

Environmental Variables:
Device: Flame 2.5 [Full Flash]
Build ID: 20150819030215
Gaia: 1e1197e0e8e64307aa382ffba4711d1c661de7ca
Gecko: f384789a29dc
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 43.0a1 (2.5)
Firmware Version: v18D-v4
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Result:
The phone does not change orientation on lockscreen or FTU
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Summary: [Lockscreen] Lockscreen can change to landscape orientation → [Aries][Lockscreen] Lockscreen can change to landscape orientation
Whiteboard: [2.5-Daily-Testing][Spark][Systemsfe]
[Blocking Requested - why for this release]:

This could lead to end user frustration so nominating this 2.5? Let's get a window here.
blocking-b2g: --- → 2.5?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
QA Contact: mshuman
This issue appears to be caused by:
Bug 1131470 - w3c screen orientation api has changed

Mozilla-inbound Regression Window:

Last Working 
Environmental Variables:
Device: Aries 2.5
BuildID: 20150819042439
Gaia: 1e1197e0e8e64307aa382ffba4711d1c661de7ca
Gecko: 4203e86db40a2fdcc52fa2f6ca263a1d9d704b91
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

First Broken 
Environmental Variables:
Device: Aries 2.5
BuildID: 20150819041446
Gaia: 1e1197e0e8e64307aa382ffba4711d1c661de7ca
Gecko: be65c38abed995c7975383836c87df21ac02bcc7
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Last Working gaia / First Broken gecko - Issue DOES reproduce
Gaia: 1e1197e0e8e64307aa382ffba4711d1c661de7ca
Gecko: be65c38abed995c7975383836c87df21ac02bcc7

First Broken gaia / Last Working gecko - Issue does NOT reproduce
Gaia: 1e1197e0e8e64307aa382ffba4711d1c661de7ca
Gecko: 4203e86db40a2fdcc52fa2f6ca263a1d9d704b91

Gecko Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=4203e86db40a2fdcc52fa2f6ca263a1d9d704b91&tochange=be65c38abed995c7975383836c87df21ac02bcc7
Blocks: 1131470
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
William this seems to be because of Bug 1131470, can you please take a look?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(wchen)
[Triage] blocked by this for inconsistent user experience.
blocking-b2g: 2.5? → 2.5+
The problem here is that the new orientation API introduces the concept of a document's orientation lock and the algorithms tell us when it's set. When the active top-level browsing context changes, we need to update the screen orientation according to the document's orientation lock (currently this isn't set when we use the old API which causes an orientation unlock every time the browsing context gets activated). This is in contrast to the old behavior where orientation locks would persist across browsing contexts until explicitly changed or unlocked.

In this patch, I've added code to update the orientation lock on browsing contexts even when using the old orientation API so it behave a bit better with the new orientation behavior. In addition, I've disabled updating the orientation when activating app docshells so that it preserves old API behavior. I did it because I noticed that apps can activate multiple docshells that look like "top-level" browsing contexts and may cause an unintentional orientation unlock following an orientation lock. Also, the new behavior can causes visual weirdness because in some cases we don't want to change orientation between switching apps, but with the new API, when the next app is loaded, we start by unlocking the orientation per spec, then the app locks the orientation. This results in a brief moment where the orientation changes, then changes back again.
Assignee: nobody → wchen
Flags: needinfo?(wchen)
Attachment #8650780 - Flags: review?(bugs)
Attachment #8650780 - Flags: review?(bugs) → review+
Duplicate of this bug: 1196709
https://hg.mozilla.org/mozilla-central/rev/bc43f663e5e1
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → FxOS-S6 (04Sep)
This bug has been verified as "pass" on the latest build of Flame KK 2.5 and Aires KK 2.5 by the STR in comment 0.

Actual results: Lockscreen can't change to landscape mode.
See attachment: verified_AriesKK_v2.5.3gp
Reproduce rate: 0/10


Device: Flame KK 2.5 (Pass)
Build ID               20150824150208
Gaia Revision          d7fb5717d3e0153ac64af2c0d5c11079846d81c3
Gaia Date              2015-08-24 10:07:41
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/ba43a48d3c528cc956335793e02504e5ca2c149f
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150824.182403
Firmware Date          Mon Aug 24 18:24:15 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK 2.5(Pass)
Build ID               20150824124704
Gaia Revision          d7fb5717d3e0153ac64af2c0d5c11079846d81c3
Gaia Date              2015-08-24 10:07:41
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/ba43a48d3c528cc956335793e02504e5ca2c149f
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150824.122007
Firmware Date          Mon Aug 24 12:20:15 UTC 2015
Bootloader             s1
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
See Also: → 1209905
Duplicate of this bug: 1209905
See Also: → 1224509
You need to log in before you can comment on or make changes to this bug.