phone keeps turning on in my pocket

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Feedback
RESOLVED WONTFIX
3 years ago
5 months ago

People

(Reporter: dietrich, Unassigned)

Tracking

({feature, foxfood})

unspecified
feature, foxfood

Firefox Tracking Flags

(blocking-b2g:2.5?, tracking-b2g:backlog, b2g-v2.2 affected, b2g-v2.5 affected, b2g-v2.2r affected, b2g-master affected)

Details

(Whiteboard: [bzlite])

(Reporter)

Description

3 years ago
User-Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Runs down the battery, causes phone to get really hot, makes screen glow in social situations unwantedly. This has got to be a bug, right?
[Blocking Requested - why for this release]: Drains battery way faster.
blocking-b2g: --- → 2.5?
Keywords: qawanted
Description and lack of STR is not helping QA here. I assume the reporter's phone was turned on, but screen was off, when they encountered this issue? As far as I know the screen turns on when showing SMS notifications, receiving phone calls and etc.

Can the reporter at least provide what the phone was trying to do when it wakes up?
Flags: needinfo?(dietrich)
(Reporter)

Comment 3

3 years ago
Device is Aries, update channel is dogfood-latest.

STR:

1. phone is on, screen is off, phone in pocket
2. pull phone from pocket

Expected: screen is off, phone is not blazing hot, battery is not lower

Actual: screen is on, phone is blazing hot, battery is lower

I've seen my phone screen turn on from sleep without my interaction sometimes when messages arrive or calendar events or clock timers hit. So it's definitely possible that this can happen. But I don't know if that's intended or a bug.
Flags: needinfo?(dietrich)

Updated

3 years ago
blocking-b2g: 2.5? → -
Keywords: qawanted → feature

Comment 4

3 years ago
[Triage] it's not a blocker. however, we'd like to have someone dig in and figure out a solution.

[Tracking Requested - why for this release]:
Wilfred, can you check if we will put it in one of our releases?
tracking-b2g: --- → backlog
Flags: needinfo?(wmathanaraj)
The question is how did you get in that state?  It normally doesn't do that by itself.
ie do you have browser running in the background?  Do you have wifi turned on?  Do you have data turned on? 

Please also provide logs.  It's hard to see what the cause is.  Otherwise it may be a duplicate of another bug.
Flags: needinfo?(dietrich)
It's possible that this may be a dup of bug 1194532
(Reporter)

Comment 7

3 years ago
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #5)
> The question is how did you get in that state?  It normally doesn't do that
> by itself.
> ie do you have browser running in the background?  Do you have wifi turned
> on?  Do you have data turned on? 
> 
> Please also provide logs.  It's hard to see what the cause is.  Otherwise it
> may be a duplicate of another bug.

I'll try to get logs when it turns on.

I always have wifi and mobile data turned on. I don't know what apps are running at the time.

(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #6)
> It's possible that this may be a dup of bug 1194532

That would be the hot part. Let's use this bug for the screen part. I just assumed that the hot was due to screen being turned on, but I could be wrong.
Flags: needinfo?(dietrich)
once it passes triage we can then nominate if it say blocker for a release
Flags: needinfo?(wmathanaraj)
(Reporter)

Comment 9

3 years ago
Confirmed: Every time I get some notification, the screen wakes up. I've seen it with Calendar notifications and Telegram so far.
Without any reproducible steps from a fresh phone, this bug is inactionable.
Can you provide at the very least the logcat that you have for the phone please?
Flags: needinfo?(dietrich)
(Reporter)

Comment 11

3 years ago
Have you tried setting up Calendar notifications? Or installed Telegram?

I'll try to get logs next time I notice it happen.
Flags: needinfo?(dietrich)
(Reporter)

Comment 12

3 years ago
I figured out part of reproduction: The screen only comes on when volume is turned all the way down.
Flags: needinfo?(nhirata.bugzilla)
QA Whiteboard: [foxfood-triage]
Do you still see this issue?
Flags: needinfo?(dietrich)
(Reporter)

Comment 14

3 years ago
Yes.

STR:

1. turn volume completely down
2. turn off screen
3. use any app that gives notifications

Whenever you get a notification the screen turns on.

I easily reproduced it by creating a calendar event for 1 minute from now, with all other settings as default, and hitting save and then immediately pressing the power button to turn the screen off. The screen turns on immediately to show the event 5 minute warning notification.
Flags: needinfo?(dietrich)
[Blocking Requested - why for this release]: We have steps now.
blocking-b2g: - → 2.5?
iPhone will buzz (vibrate) but keep the screen off if you have the vibrate on silent mode on.  Otherwise you get no notification.

If you have the vibrate on, on the Firefox OS, it will turn on and vibrate.

This happens on 2.2 as well.  I'm not sure that this was a regression to begin with...  (ie it might have been by design?)

The heat issue was due to other causes I believe.  I don't think this is specifically a 2.5 blocker, though we should change it.
status-b2g-v2.2: --- → affected
status-b2g-v2.2r: --- → affected
status-b2g-v2.5: --- → affected
status-b2g-master: --- → affected
Flags: needinfo?(nhirata.bugzilla) → needinfo?(firefoxos-ux-bugzilla)
From UX triage:

We don't really see a reason for the screen to be turning after a vibrate especially since it's just draining the battery. It should remain off.

Thanks for pinging the UX team!
Flags: needinfo?(firefoxos-ux-bugzilla)

Comment 18

5 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.