EFF Privacy Badger can't be installed on Developer Edition

RESOLVED INVALID

Status

()

Toolkit
Add-ons Manager
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: Alex Bell, Unassigned)

Tracking

42 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20150819004006

Steps to reproduce:

Visit https://www.eff.org/privacybadger
in Developer Edition. Click to install, and click allow.






Actual results:

No install.

"Firefox Developer Edition has prevented this site from installing an unwanted add on."


Expected results:

Ordinary installation of the add-on. I tested on FF 40.0.2 and Privacy Badger installs as expected. Not sure why Dev Edition is doing something different.

Comment 1

3 years ago
I don't know this add-on but maybe it's unsigned.
Could you test with xpinstall.signatures.required=false in about:config.
Component: Untriaged → Add-ons Manager
Flags: needinfo?(alex)
Product: Firefox → Toolkit
(Reporter)

Comment 2

3 years ago
Thanks. Yes, with xpinstall.signatures.required=false Privacy Badger installs without any issue.

I figured out what's happening. There has been a change in 42. Unsigned extensions are no longer installable. https://wiki.mozilla.org/Addons/Extension_Signing
Flags: needinfo?(alex)
(Reporter)

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.