places.history.expiration.max_pages set to "99999" is ignored

RESOLVED WONTFIX

Status

()

Firefox
Bookmarks & History
RESOLVED WONTFIX
3 years ago
2 months ago

People

(Reporter: ildar, Unassigned)

Tracking

39 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:39.0) Gecko/20100101 Firefox/39.0
Build ID: 20150810112730

Steps to reproduce:

I upgraded firefox-38.0.6 to firefox-39.0.3


Actual results:

places.sqlite shrunk



Expected results:

While my places.history.expiration.max_pages and places.history.expiration.transient_current_max_pages are set to "99999" I expect that my history is preserved. But now it is vanished.

Updated

3 years ago
Component: Untriaged → Bookmarks & History

Updated

3 years ago
Summary: places.history.expiration.max_pages is ignored → places.history.expiration.max_pages set to "99999" is ignored
Likely your database was corrupt, maybe exactly due to an unrealistic history limit. On upgrade to Firefox 39 the corruption was hit, and the database replaced (bookmarks are restored but history is not) with a sane one.
You can try recovering your old places.sqlite-corrupt using the hints from this page:
https://developer.mozilla.org/en-US/docs/Mozilla/Tech/Places/places.sqlite_Database_Troubleshooting
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 2

3 years ago
(In reply to Marco Bonardo [::mak] (spotty available until 24 Aug) from comment #1)
> Likely your database was corrupt

I suggest the DB was not corrupt as `places.sqlite-corrupt` is absent.
There's no other known way for history to disappear than a corruption or selecting clear history (or clear history on shutdown)...
How old is your oldest visit in history?
You need to log in before you can comment on or make changes to this bug.