mouseup event return false

RESOLVED DUPLICATE of bug 1194733

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 1194733
3 years ago
3 years ago

People

(Reporter: Dmitry Poddubniy, Unassigned)

Tracking

40 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/46.0.2478.0 Safari/537.36

Steps to reproduce:

Use select with change event and document with mouseup event.

can be verified by http://jsfiddle.net/mr47/2uuym703/

Work for me on Windows 10 and Linux.


Actual results:

if mouseup event return false select box change event dont fires

result of fiddle on ff 40:
document fire event count: 7 


Expected results:

when select box triggers mouseup event and return false, change event on select box must fires too.

document fire event count: 7 
change fire event count: 3

PS:

Can be fixed by returning not false value on mouseup event

Comment 1

3 years ago
maybe dup of bug 1194733

Comment 2

3 years ago
yes, same regression range
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1194733
You need to log in before you can comment on or make changes to this bug.