Closed Bug 1196402 Opened 7 years ago Closed 7 years ago

HttpServiceRequests issued from Flash stop before downloading entire content in v40+

Categories

(Core :: Plug-ins, defect)

40 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1194600

People

(Reporter: dgmeisen, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0
Build ID: 20150806001005

Steps to reproduce:

Had a working FlashPlayer app written in adobe flex.

I issue 2 servlet requests after .swf is loaded, one retreiving over 300KB, the other retrieving about 30KB.


Actual results:

The requests start to download, as seen in firebug but then stop before reaching the full content length.  They often but not always stop at the same point 26.2KB into the file.  Flash then throws a 2302 stream error.

This happens in FF40, but not in FF39 or in latest IE or Chrome, so it does not appear to actually be a flashplayer issue.  Running in Firefox safe mode did not improve results.


Expected results:

Content for both requests downloads fully (as it did in Firefox 39)
Set about:config > dom.ipc.plugins.asyncInit = false as local workaround.

Hotfix is coming in bug 1196000.
Component: Untriaged → Plug-ins
(In reply to Loic from comment #1)
> Set about:config > dom.ipc.plugins.asyncInit = false as local workaround.
> 
> Hotfix is coming in bug 1196000.

Thanks so much, that was fast!  The hotfix seems to have taken care of this.  Should I mark as duplicate of 1196000 for you?
Nope, your bug report is the issue, bug 1196000 is the fix, and as dependencies are already set, it's fine.
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1194600
Can you please try with Firefox 41 beta 5 where the pref is set to true by default as this should be fixed. Please let us know your results. Thank you!

https://ftp.mozilla.org/pub/mozilla.org/firefox/candidates/41.0b5-candidates/build1/
Flags: needinfo?(dgmeisen)
Yes, 41b5 works for me.  Thank you for verifying.
Flags: needinfo?(dgmeisen)
You need to log in before you can comment on or make changes to this bug.