can't load new image into HTMLImageElement with src not available

RESOLVED DUPLICATE of bug 22820

Status

()

RESOLVED DUPLICATE of bug 22820
17 years ago
17 years ago

People

(Reporter: martin.honnen, Assigned: jst)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
When I have 
  <img name="imageName" src="notexistingImage.gif" alt="some image" />
then Mozilla displays the alt text but doesn't load a new image when you set
the src property 
  document.imageName.src = 'existingImage.gif'
This is not compliant with NN4 or IE6 which for instance allow the
  <img onerror
handler to set the src to an existing img element and load that. Mozilla sets
the src property but fails to load the image.
I will upload a test case.
(Reporter)

Comment 1

17 years ago
Created attachment 64658 [details]
image needed for test case
(Reporter)

Comment 2

17 years ago
Created attachment 64661 [details]
test case 

There are two <img> elements in the test page, the first has onload and onerror
handlers set up to show whether those work, it seems that they work in Mozilla
(at least for the first load attempt). The test output is directed to a
textarea element.
The second <img> element tries to load an existing image in its onload handler
which works in NN4 and IE6 but not in Mozilla.
The form also allows with a select element to attempt to load an image into the
first <img> element which also works in NN4 and IE6 but not with Mozilla.

Comment 3

17 years ago
Does the old bug 22820 cover your problems?
(Reporter)

Comment 4

17 years ago
If http://bugzilla.mozilla.org/show_bug.cgi?id=106719 is a duplicate of
http://bugzilla.mozilla.org/show_bug.cgi?id=22820 then this is too. 

*** This bug has been marked as a duplicate of 22820 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.