If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Intermittent dom/media/tests/mochitest/test_getUserMedia_callbacks.html | application terminated with exit code 11 | application crashed [@ libc-2.15.so + 0x136b9d] | Assertion in cairo: Assertion `array->num_elements + num_elements <= array->size' faile

RESOLVED DUPLICATE of bug 1196565

Status

()

Core
WebRTC
RESOLVED DUPLICATE of bug 1196565
2 years ago
2 years ago

People

(Reporter: nigelb, Unassigned)

Tracking

({intermittent-failure})

Trunk
intermittent-failure
Points:
---

Firefox Tracking Flags

(firefox43 affected)

Details

(URL)

(Reporter)

Description

2 years ago
https://treeherder.mozilla.org/logviewer.html#?job_id=2567867&repo=b2g-inbound

1:42:22 INFO - 4324 INFO TEST-PASS | dom/media/tests/mochitest/test_getUserMedia_callbacks.html | A valid string reason is expected
01:42:22 INFO - 4325 INFO TEST-PASS | dom/media/tests/mochitest/test_getUserMedia_callbacks.html | Reason cannot be empty
01:42:22 INFO - 4326 INFO TEST-PASS | dom/media/tests/mochitest/test_getUserMedia_callbacks.html | One audio track shall be present
01:42:22 INFO - 4327 INFO TEST-PASS | dom/media/tests/mochitest/test_getUserMedia_callbacks.html | Track kind should be audio
01:42:22 INFO - 4328 INFO TEST-PASS | dom/media/tests/mochitest/test_getUserMedia_callbacks.html | Track id should be defined
01:42:22 INFO - 4329 INFO TEST-PASS | dom/media/tests/mochitest/test_getUserMedia_callbacks.html | No video tracks shall be present
01:42:22 INFO - 4330 INFO TEST-PASS | dom/media/tests/mochitest/test_getUserMedia_callbacks.html | Stream should be a LocalMediaStream
01:42:22 INFO - 4331 INFO TEST-PASS | dom/media/tests/mochitest/test_getUserMedia_callbacks.html | Before starting the media element, currentTime = 0
01:42:22 INFO - 4332 INFO TEST-FAIL | dom/media/tests/mochitest/test_getUserMedia_callbacks.html | The author of the test has indicated that flaky timeouts are expected. Reason: WebRTC inherently depends on timeouts
01:42:22 INFO - 4333 INFO TEST-PASS | dom/media/tests/mochitest/test_getUserMedia_callbacks.html | Media element should be playing
01:42:22 INFO - 4334 INFO TEST-PASS | dom/media/tests/mochitest/test_getUserMedia_callbacks.html | Duration should be infinity
01:42:22 INFO - 4335 INFO TEST-PASS | dom/media/tests/mochitest/test_getUserMedia_callbacks.html | Ready state shall be HAVE_ENOUGH_DATA or HAVE_CURRENT_DATA
01:42:22 INFO - 4336 INFO TEST-PASS | dom/media/tests/mochitest/test_getUserMedia_callbacks.html | Seekable length shall be zero
01:42:22 INFO - 4337 INFO TEST-PASS | dom/media/tests/mochitest/test_getUserMedia_callbacks.html | Buffered length shall be zero
01:42:22 INFO - 4338 INFO TEST-PASS | dom/media/tests/mochitest/test_getUserMedia_callbacks.html | MediaElement is not seekable with MediaStream
01:42:22 INFO - 4339 INFO TEST-PASS | dom/media/tests/mochitest/test_getUserMedia_callbacks.html | Start offset time shall not be a number
01:42:22 INFO - 4340 INFO TEST-PASS | dom/media/tests/mochitest/test_getUserMedia_callbacks.html | Loop shall be false
01:42:22 INFO - 4341 INFO TEST-PASS | dom/media/tests/mochitest/test_getUserMedia_callbacks.html | Preload should not exist
01:42:22 INFO - 4342 INFO TEST-PASS | dom/media/tests/mochitest/test_getUserMedia_callbacks.html | No src should be defined
01:42:22 INFO - 4343 INFO TEST-PASS | dom/media/tests/mochitest/test_getUserMedia_callbacks.html | Current src should still be an empty string
01:42:22 INFO - 4344 INFO TEST-FAIL | dom/media/tests/mochitest/test_getUserMedia_callbacks.html | The author of the test has indicated that flaky timeouts are expected. Reason: WebRTC inherently depends on timeouts
01:42:22 WARNING - TEST-UNEXPECTED-FAIL | dom/media/tests/mochitest/test_getUserMedia_callbacks.html | application terminated with exit code 11
01:42:22 INFO - runtests.py | Application ran for: 0:00:40.899999
01:42:22 INFO - zombiecheck | Reading PID log: /tmp/tmpIvFreipidlog
01:42:22 INFO - mozcrash Downloading symbols from: https://queue.taskcluster.net/v1/task/QuGmWpEfR-6B8sy1kNW_BA/artifacts/public/build/firefox-43.0a1.en-US.linux-i686.crashreporter-symbols.zip
01:42:49 INFO - mozcrash Saved minidump as /builds/slave/test/build/blobber_upload_dir/2cdc5c01-f5c6-557d-504d9004-78049da2.dmp
01:42:49 INFO - mozcrash Saved app info as /builds/slave/test/build/blobber_upload_dir/2cdc5c01-f5c6-557d-504d9004-78049da2.extra
01:42:49 WARNING - PROCESS-CRASH | dom/media/tests/mochitest/test_getUserMedia_callbacks.html | application crashed [@ libc-2.15.so + 0x136b9d]
01:42:49 INFO - Crash dump filename: /tmp/tmpGg4kmt.mozrunner/minidumps/2cdc5c01-f5c6-557d-504d9004-78049da2.dmp
01:42:49 INFO - Operating system: Linux
01:42:49 INFO - 0.0.0 Linux 3.2.0-76-generic-pae #111-Ubuntu SMP Tue Jan 13 22:34:29 UTC 2015 i686
01:42:49 INFO - CPU: x86
01:42:49 INFO - GenuineIntel family 6 model 62 stepping 4
01:42:49 INFO - 1 CPU
01:42:49 INFO - Crash reason: SIGSEGV
01:42:49 INFO - Crash address: 0x0
01:42:49 INFO - Process uptime: not available
01:42:49 INFO - Thread 24 (crashed)
01:42:49 INFO - 0 libc-2.15.so + 0x136b9d
01:42:49 INFO - eip = 0xb7553b9d esp = 0xa3c54b08 ebp = 0x0000000c ebx = 0xb7553b98
01:42:49 INFO - esi = 0x9a85b050 edi = 0x00000000 eax = 0xa3c54ba0 ecx = 0x0000000c
01:42:49 INFO - edx = 0x0000000c efl = 0x00010283
01:42:49 INFO - Found by: given as instruction pointer in context
01:42:49 INFO - 1 libcairo.so.2.11000.2 + 0xc7ff4
01:42:49 INFO - eip = 0xb68f1ff4 esp = 0xa3c54b0c ebp = 0x0000000c
01:42:49 INFO - Found by: stack scanning
01:42:49 INFO - 2 libcairo.so.2.11000.2 + 0xb5ec
01:42:49 INFO - eip = 0xb68355ec esp = 0xa3c54b10 ebp = 0x0000000c
01:42:49 INFO - Found by: stack scanning
01:42:49 INFO - 3 firefox!je_malloc [jemalloc.c:21efe01b6680 : 6141 + 0xb]
01:42:49 INFO - eip = 0x08063bfb esp = 0xa3c54b3c ebp = 0x0000000c
01:42:49 INFO - Found by: stack scanning
01:42:49 INFO - 4 libcairo.so.2.11000.2 + 0xc7ff4
01:42:49 INFO - eip = 0xb68f1ff4 esp = 0xa3c54b40 ebp = 0x0000000c
01:42:49 INFO - Found by: stack scanning
01:42:49 INFO - 5 libgdk-3.so.0.400.1 + 0x7aa88
01:42:49 INFO - eip = 0xb6ae0a88 esp = 0xa3c54b48 ebp = 0x0000000c
01:42:49 INFO - Found by: stack scanning
01:42:49 INFO - 6 libcairo.so.2.11000.2 + 0xb652
01:42:49 INFO - eip = 0xb6835652 esp = 0xa3c54b50 ebp = 0xa3c54cb8
01:42:49 INFO - Found by: stack scanning
01:42:49 INFO - 7 libxul.so!nsWindow::StartRemoteDrawing() [nsWindow.cpp:21efe01b6680 : 6185 + 0x1a]
01:42:49 INFO - eip = 0xb375a8e1 esp = 0xa3c54cc0 ebp = 0xa3c54d18
01:42:49 INFO - Found by: previous frame's frame pointer
01:42:49 INFO - 8 libxul.so!mozilla::layers::BasicCompositor::BeginFrame(nsIntRegion const&, mozilla::gfx::RectTyped<mozilla::gfx::UnknownUnits> const*, mozilla::gfx::RectTyped<mozilla::gfx::UnknownUnits> const&, mozilla::gfx::RectTyped<mozilla::gfx::UnknownUnits>*, mozilla::gfx::RectTyped<mozilla::gfx::UnknownUnits>*) [BasicCompositor.cpp:21efe01b6680 : 517 + 0x1b]
01:42:49 INFO - eip = 0xb2a4baf1 esp = 0xa3c54d20 ebp = 0xa3c54dc8 ebx = 0xb6139730
01:42:49 INFO - esi = 0xa3c54d98 edi = 0xa3c54e70
01:42:49 INFO - Found by: call frame info
Comment hidden (Treeherder Robot)
before all the logs from the final test:
/build/buildd/cairo-1.10.2/src/cairo-array.c:320: _cairo_array_allocate: Assertion `array->num_elements + num_elements <= array->size' failed.
Summary: Intermittent dom/media/tests/mochitest/test_getUserMedia_callbacks.html | application terminated with exit code 11 | application crashed [@ libc-2.15.so + 0x136b9d] → Intermittent dom/media/tests/mochitest/test_getUserMedia_callbacks.html | application terminated with exit code 11 | application crashed [@ libc-2.15.so + 0x136b9d] | Assertion in cairo: Assertion `array->num_elements + num_elements <= array->size' faile

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1196565
You need to log in before you can comment on or make changes to this bug.