Font rendering becomes grainy after scroll

RESOLVED DUPLICATE of bug 1122916

Status

()

Core
Graphics: Text
RESOLVED DUPLICATE of bug 1122916
3 years ago
2 years ago

People

(Reporter: larsberg, Unassigned)

Tracking

43 Branch
x86_64
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8650416 [details]
DevOKFonts.tiff

If you go to a site with a lot of text (I see it on IRCCloud), Nightly will first render nicely, but as soon as you scroll, the fonts become fainter and grainy. This does not occur on the dev versions listed below.

Helvetica Neue system font (from the font inspector)
Dev - 42.0a2 (2015-08-19)
Nightly - 43.0a1 (2015-08-19)

This does not happen on the retina display on the macbook; only on windows that are on my external monitor (verified on both a Mozilla-previous-standard 27" Dell U2713H and an Apple Thunderbolt 27").
(Reporter)

Comment 1

3 years ago
Created attachment 8650417 [details]
NightlyBadFontRendering.tiff
It looks like (a) much of the text is getting grayscale AA instead of subpixel AA; and (b) for the pieces that do still have some kind of subpixel rendering, the component order may be flipped (BGR vs RGB).

(I think there have been other reports similar to this, but don't have the appropriate bug # offhand.)
Is this a regression?
Flags: needinfo?(larsberg)
(Reporter)

Comment 4

3 years ago
I don't know if it's a regression. I've always been on the aurora/dev channel. Is there something I can do to help find that out?
Flags: needinfo?(larsberg)
Probably a dupe of bug 1122916?
Oh actually maybe not. Do you have the pref layers.async-pan-zoom.enabled set to true in your devedition build? If not then it may be something else.
(Reporter)

Comment 7

3 years ago
That pref is set to true in nightly, but it is set to false in my devedition build.
(In reply to Lars Bergstrom (:larsberg) from comment #4)
> I don't know if it's a regression. I've always been on the aurora/dev
> channel. Is there something I can do to help find that out?
You can check if you see the problem on the same sites in old version of Firefox.
(Reporter)

Comment 9

3 years ago
Confirmed that setting `layers.async-pan-zoom.enabled` to false on nightly makes the fonts readable again.
But you're seeing the same issue on DevEdition, and there the pref is already set to false? There might be separate causes for the same issue on the two channels.
(Reporter)

Comment 11

3 years ago
Sorry for being unclear. If the pref is set to true, I see the poor fonts in either DevEdition or Nightly. If I set the pref to false, I see good fonts in both DevEdition and Nightly.
Ok, thanks. This is the same issue as bug 1122916 then.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1122916
You need to log in before you can comment on or make changes to this bug.