Items shared to reading list from external app don't load properly

RESOLVED DUPLICATE of bug 1200694

Status

()

Firefox for iOS
Reading List
RESOLVED DUPLICATE of bug 1200694
3 years ago
3 years ago

People

(Reporter: nwgh, Unassigned)

Tracking

({reproducible})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
I've noticed lately that if I share a link to the reading list (especially from the twitter app), when I go to view that in Firefox, there is no snippet of text from the link in the reading list, and when I tap on the item to load it, I get a page with the reading list controls showing the t.co URL in the URL bar, and the network activity indicator in the iOS top bar spins indefinitely. I can only get the content (in non-reading mode) by tapping the URL bar and hitting "go" (which causes the page to reload entirely).

I *would* suspect this has something to do with the t.co redirects, but I also have a direct URL in my reading list that exhibits the same behavior. (I don't remember where I shared that URL from, perhaps safari?)

Updated

3 years ago
tracking-fxios: --- → ?

Updated

3 years ago
Keywords: reproducible
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1197399
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Reopening this. We need to investigate this. It may be related to bug 1197399 or may be a separate issue.

Sharing a page from a different app to reading list results in a very different process (we run the readability code in a different webview, not connected to any of the delegates on which we made changes for bug 1197399) - it is simpler so maybe also easier to debug.
File separate bugs?
Flags: needinfo?(sarentz)
I filed a new bug for the first issue to which I will dupe this bug. Will file a second bug for the other issue mentioned.
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Flags: needinfo?(sarentz)
Resolution: --- → DUPLICATE
Duplicate of bug: 1200694
Filed 1200699 Reading list does not resolve shortened URLs
tracking-fxios: ? → ---
You need to log in before you can comment on or make changes to this bug.